
<!doctype html>
<html prefix="og: http://ogp.me/ns#" lang="en-gb" dir="ltr">
<head>

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-80147-10"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-80147-10');
</script>
<meta charset="utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no">
<link rel="canonical" href="https://speedwaydigest.com/index.php/news/speedway-news/59396-panella-moles-parreira-and-maulding-win-turkey-bowl-xx-features-on-saturday-at-delta">
<base href="https://speedwaydigest.com/index.php/news/speedway-news/59396-panella-moles-parreira-and-maulding-win-turkey-bowl-xx-features-on-saturday-at-delta" />
<meta http-equiv="content-type" content="text/html; charset=utf-8" />
<meta name="keywords" content="NASCAR, NASCAR News, NASCAR Drivers, NASCAR Frequencies, Monster Cup, XFINITY, Camping World, NASCAR Points, Speedway Digest, Speedway Digest NASCAR News, Daytona, Richmond, Martinsville, Dover, Charlotte, Darlington, North Wilkesboro, Texas Motor Speedway, Pocono Speedway, Watkins Glen, Auto Club Speedway, Bristol Motor Speedway, Kansas Speedway, Talladega Superspeedway, Atlanta Motor Speedway, News, Jimmie Johnson, Roush Racing, Hendricks Motorsports, BK Racing, Wood Brothers Racing, Richard Petty Motorsports, Yates Racing, Robert Yates Racing, Michael Waltrip Racing, Carl Edwards, Trevor Bayne, Save The Speedway, North Wilkesboro Speedway, Dale Earnhardt, Dale Earnhardt Jr., NASCAR Frequencies, Monster Energy NASCAR Cup Series, Monster Energy Series, XFINITY Series, Camping World Truck Series, Las Vegas Motor Speedway, Phoenix International Raceway, Charlotte Motor Speedway, New Hampshire Motor Speedway, Gateway Motorsports Park, Darlington Raceway, Ryan Blaney, Chase Elliott, Ford Performance, Team Chevy, Toyota Racing, Kyle Busch, Kurt Busch, Denny Hamlin, NASCAR schedule, nascar race today, nascar race schedule, nascar race results, nascar race this weekend, nascar race results today, nascar truck race, nascar trucks, where is the nascar race today, nascar xfinity race, nascar schedule, nascar news, daytona 500, nascar race today, nascar today, nascar race, nascar results, nascar race schedule, nascar live, race scanner, racing scanner, race scanners" />
<meta name="rights" content="Copyright - Steven B. Wilson - STS Motorsports Inc. 2005 - 2020" />
<meta name="author" content="Speedway Digest Staff" />
<meta property="og:url" content="https://www.speedwaydigest.com/index.php/news/speedway-news/59396-panella-moles-parreira-and-maulding-win-turkey-bowl-xx-features-on-saturday-at-delta" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Panella, Moles, Parreira and Maulding win Turkey Bowl XX features on Saturday at Delta" />
<meta property="og:description" content="Stockton’s Alex Panella and Watsonville’s Rickey Sanders put on a thrilling show over the closing laps to help finish off the season at Delta Speedway on Saturday. In the end it was Panella prevailing at the checkered flag to scoop up the $2,000 grand prize with the Super 600s at Turkey Bowl XX. Rai..." />
<meta property="og:image" content="https://www.speedwaydigest.com/media/k2/items/cache/5c2ebf43c77043a0f15634f30ba303b2_M.jpg" />
<meta name="image" content="https://www.speedwaydigest.com/media/k2/items/cache/5c2ebf43c77043a0f15634f30ba303b2_M.jpg" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:title" content="Panella, Moles, Parreira and Maulding win Turkey Bowl XX features on Saturday at Delta" />
<meta name="twitter:description" content="Stockton’s Alex Panella and Watsonville’s Rickey Sanders put on a thrilling show over the closing laps to help finish off the season at Delta Speedway on Saturday. In the end it was Panella prevailing..." />
<meta name="twitter:image" content="https://www.speedwaydigest.com/media/k2/items/cache/5c2ebf43c77043a0f15634f30ba303b2_M.jpg" />
<meta name="twitter:image:alt" content="Panella, Moles, Parreira and Maulding win Turkey Bowl XX features on Saturday at Delta" />
<meta name="description" content="Stockton’s Alex Panella and Watsonville’s Rickey Sanders put on a thrilling show over the closing laps to help finish off the season at Delta Speedway..." />
<title>Panella, Moles, Parreira and Maulding win Turkey Bowl XX features on Saturday at Delta</title>
<link href="/index.php/news/speedway-news/59396-panella-moles-parreira-and-maulding-win-turkey-bowl-xx-features-on-saturday-at-delta" rel="canonical" />
<link href="https://speedwaydigest.com/index.php/news/speedway-news/59396-panella-moles-parreira-and-maulding-win-turkey-bowl-xx-features-on-saturday-at-delta/amp" rel="amphtml" />
<link href="/images/favicon.ico" rel="shortcut icon" type="image/vnd.microsoft.icon" />
<link href="/favicon.ico" rel="shortcut icon" type="image/vnd.microsoft.icon" />
<link href="https://cdn.jsdelivr.net/npm/magnific-popup@1.1.0/dist/magnific-popup.min.css" rel="stylesheet" type="text/css" />
<link href="https://cdn.jsdelivr.net/npm/simple-line-icons@2.4.1/css/simple-line-icons.css" rel="stylesheet" type="text/css" />
<link href="/templates/ts_newslinen/css/k2.css?v=2.10.3" rel="stylesheet" type="text/css" />
<link href="//fonts.googleapis.com/css?family=PT+Serif:100,100i,300,300i,400,400i,500,500i,700,700i,900,900i&amp;display=swap&amp;subset=cyrillic-ext" rel="stylesheet" type="text/css" />
<link href="//fonts.googleapis.com/css?family=Roboto:100,100i,300,300i,400,400i,500,500i,700,700i,900,900i&amp;display=swap&amp;subset=cyrillic-ext" rel="stylesheet" type="text/css" />
<link href="//fonts.googleapis.com/css?family=Heebo:100,100i,300,300i,400,400i,500,500i,700,700i,900,900i&amp;display=swap&amp;subset=latin" rel="stylesheet" type="text/css" />
<link href="//fonts.googleapis.com/css?family=Heebo:100,100i,300,300i,400,400i,500,500i,700,700i,900,900i&amp;display=swap&amp;subset=hebrew" rel="stylesheet" type="text/css" />
<link href="/cache/com_templates/templates/ts_newslinen/bb68c47fa99bad52a439740ae950c614.css" rel="stylesheet" type="text/css" />
<link href="/modules/mod_sp_social/assets/css/default/sp_social.css" rel="stylesheet" type="text/css" />
<style type="text/css">

                        /* K2 - Magnific Popup Overrides */
                        .mfp-iframe-holder {padding:10px;}
                        .mfp-iframe-holder .mfp-content {max-width:100%;width:100%;height:100%;}
                        .mfp-iframe-scaler iframe {background:#fff;padding:10px;box-sizing:border-box;box-shadow:none;}
                    body.site {background-image: url(/images/bg1.jpg);background-repeat: repeat;background-size: cover;background-attachment: fixed;background-position: 0 0;}#sp-footer2 .sp-module ul > li {
border-bottom: 0 none;
padding: 0.3em;
display: inline;
float: top;
}body{font-family: 'PT Serif', sans-serif;font-size: 14px;font-weight: 400;font-style: normal;}
h1{font-family: 'Roboto', sans-serif;font-size: 30px;font-weight: 500;font-style: normal;}
h2{font-family: 'Roboto', sans-serif;font-size: 30px;font-weight: 500;}
h3{font-family: 'Roboto', sans-serif;font-size: 24px;font-weight: 500;}
h4{font-family: 'Roboto', sans-serif;font-size: 20px;font-weight: 500;font-style: normal;}
.sp-megamenu-parent > li > a, .sp-megamenu-parent > li > span, .sp-megamenu-parent .sp-dropdown li.sp-menu-item > a{font-family: 'Heebo', sans-serif;font-weight: 700;}
.nspInfo .nspCategory, .sppb-meta-category .nspCategory,
.ts-post-tab-list .sppb-nav-tabs li a,
.ts-bottom-social ul li a .ts-social-title,
.btn,
.sppb-meta-category a{font-family: 'Heebo', sans-serif;}
.logo-image {height:50px;}#sp-top-bar{ background-color:#2c2c2c;color:#ffffff;padding:4px 0px 4px 0px; }#sp-top-bar a{color:#ffffff;}#sp-logo-area{ background-color:#ffffff;padding:20px 15px 20px 20px;margin:0px 0px 0px 0px; }#sp-menu{ background-color:#2c2c2c;padding:0px; }#sp-main-body{ background-color:#ffffff; }#sp-footer{ background-color:#171717;color:#ffffff;padding:20px 0; }#sp-footer a{color:#ffffff;}
	</style>
<script src="/media/jui/js/jquery.min.js?9455fb5973a8d451665a733280a3b03c" type="text/javascript"></script>
<script src="/media/jui/js/jquery-noconflict.js?9455fb5973a8d451665a733280a3b03c" type="text/javascript"></script>
<script src="/media/jui/js/jquery-migrate.min.js?9455fb5973a8d451665a733280a3b03c" type="text/javascript"></script>
<script src="https://cdn.jsdelivr.net/npm/magnific-popup@1.1.0/dist/jquery.magnific-popup.min.js" type="text/javascript"></script>
<script src="/media/k2/assets/js/k2.frontend.js?v=2.10.3&b=20191219&sitepath=/" type="text/javascript"></script>
<script src="/media/plg_content_osembed/js/osembed.js?8ce873881b96af3f944e095c64350757" type="text/javascript"></script>
<script src="/templates/ts_newslinen/js/popper.min.js" type="text/javascript"></script>
<script src="/templates/ts_newslinen/js/bootstrap.min.js" type="text/javascript"></script>
<script src="/templates/ts_newslinen/js/owl-carousel.2.3.0.min.js" type="text/javascript"></script>
<script src="/templates/ts_newslinen/js/jquery.mCustomScrollbar.concat.min.js" type="text/javascript"></script>
<script src="/templates/ts_newslinen/js/main.js" type="text/javascript"></script>
<script type="application/ld+json">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</script>
<script type="text/javascript">
template="ts_newslinen";
	</script>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-4983971213106691",
          enable_page_level_ads: true
     });
</script>
<script async custom-element="amp-ad" src="https://cdn.ampproject.org/v0/amp-ad-0.1.js"></script>
<script async custom-element="amp-auto-ads" src="https://cdn.ampproject.org/v0/amp-auto-ads-0.1.js">
</script>
<meta property="fb:pages" content="173396959362248" />
<script type="application/javascript" src="//ced.sascdn.com/tag/3265/smart.js" async></script>
<script type="application/javascript">
    var sas = sas || {};
    sas.cmd = sas.cmd || [];
    sas.cmd.push(function() {
        sas.setup({ networkid: 3265, domain: "//www15.smartadserver.com", async: true });
    });
    sas.cmd.push(function() {
        sas.call("onecall", {
            siteId: 279235,
            pageId: 1033637,
            formats: [
                 { id: 71430 }
                ,{ id: 71427 }
                ,{ id: 71428 }
            ],
            target: ''
        });
    });
</script>
<script type="text/javascript">
var show_popup=1;
jQuery(document).bind("contextmenu", function(e) { if (show_popup==0) e.preventDefault(); else {e.preventDefault();jQuery('#openModal').css('opacity','1');jQuery('#openModal').css('pointer-events','auto');} });
jQuery(document).ready(function() {
    jQuery(document).on("click","#close",function() {
        jQuery('#openModal').css('opacity','0');
        jQuery('#openModal').css('pointer-events','none');
    });
});
</script><style type="text/css">
	.modalDialog {
	position: fixed;
	font-family: Arial, Helvetica, sans-serif;
	top: 0;
	right: 0;
	bottom: 0;
	left: 0;
	background: rgba(0,0,0,0.8);
	z-index: 99999;
	opacity:0;
	-webkit-transition: opacity 400ms ease-in;
	-moz-transition: opacity 400ms ease-in;
	transition: opacity 400ms ease-in;
pointer-events: none;
}

.modalDialog:target {
	opacity:1;
	pointer-events: auto;
}

.modalDialog > div {
	width: 400px;
	position: relative;
	margin: 10% auto;
	padding: 5px 20px 13px 20px;
	border-radius: 10px;
	background: #fff;
	background: -moz-linear-gradient(#fff, #999);
	background: -webkit-linear-gradient(#fff, #999);
	background: -o-linear-gradient(#fff, #999);
}

.close {
	background: #606061;
	color: #FFFFFF;
	line-height: 25px;
	position: absolute;
	right: -12px;
	text-align: center;
	top: -10px;
	width: 24px;
	text-decoration: none;
	font-weight: bold;
	-webkit-border-radius: 12px;
	-moz-border-radius: 12px;
	border-radius: 12px;
	-moz-box-shadow: 1px 1px 3px #000;
	-webkit-box-shadow: 1px 1px 3px #000;
	box-shadow: 1px 1px 3px #000;
}

.close:hover { background: #00d9ff; }
</style>
<script type="text/javascript">
	function disableSelection(target){
	if (typeof target.onselectstart!="undefined") // IE
		target.onselectstart=function(){return false}
	else if (typeof target.style.MozUserSelect!="undefined") // Firefox
		target.style.MozUserSelect="none"
	else // Opera etc
		target.onmousedown=function(){return false}
	target.style.cursor = "default"
	}
</script>
<script type="text/javascript">
		window.addEvent('domready', function() {
			document.body.oncopy = function() {
				return false;
			}
		});
</script>
<meta http-equiv="imagetoolbar" content="no">
</head>
<body class="site helix-ultimate com-k2 view-item layout-default task-none itemid-190 en-gb ltr sticky-header layout-boxed offcanvas-init offcanvs-position-right">
<div class="body-wrapper">
<div class="body-innerwrapper">
<section id="sp-top-bar" class="ts-top-bar-classic d-none d-sm-none d-md-block"><div class="container"><div class="container-inner"><div class="row"><div id="sp-top1" class="col-lg-2 "><div class="sp-column "><div class="sp-module "><div class="sp-module-content">
<div id="ts_date155" class="ts_date_area ">
<i class="fa fa-clock-o"> </i>
Monday, Oct 26</div></div></div></div></div><div id="sp-top-menu" class="col-lg-3  d-md-none d-lg-block"><div class="sp-column "></div></div><div id="sp-top3" class="col-lg-7 "><div class="sp-column ts-top-social text-right"><ul class="social-icons"><li class="social-icon-facebook"><a ondragstart="return false;" target="_blank" href="https://www.facebook.com/speedwaydigest" aria-label="facebook"><span class="fa fa-facebook" aria-hidden="true"></span></a></li><li class="social-icon-twitter"><a ondragstart="return false;" target="_blank" href="https://www.twitter.com/speedwaydigest" aria-label="twitter"><span class="fa fa-twitter" aria-hidden="true"></span></a></li><li class="social-icon-pinterest"><a ondragstart="return false;" target="_blank" href="https://www.pinterest.com/speedwaydigest/" aria-label="Pinterest"><span class="fa fa-pinterest" aria-hidden="true"></span></a></li><li><a ondragstart="return false;" target="_blank" href="https://www.youtube.com/channel/UCEHcjt3lx140xojhPUEYZ0A" aria-label="Youtube"><span class="fa fa-youtube" aria-hidden="true"></span></a></li></ul></div></div></div></div></div></section><section id="sp-logo-area"><div class="container"><div class="container-inner"><div class="row"><div id="sp-logo" class="col-md-4 col-lg-3 "><div class="sp-column "><div class="logo"><a ondragstart="return false;" href="/"><img ondragstart="return false;" class="logo-image d-none d-lg-inline-block" src="/images/sdlogoweb.fw.png" alt="Speedway Digest - Home for NASCAR News"><img ondragstart="return false;" class="logo-image-phone d-inline-block d-lg-none" src="/images/sdlogoweb.fw.png" alt="Speedway Digest - Home for NASCAR News"></a></div></div></div><div id="sp-top-banner-2" class="col-md-8 col-lg-9 d-none d-sm-none d-md-block"><div class="sp-column "><div class="sp-module "><div class="sp-module-content">
<div class="custom">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-4983971213106691" data-ad-slot="7293211960" data-ad-format="auto"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
</div></div></div></div></div></div></div></section><section id="sp-menu" class="ts-nav-box"><div class="container"><div class="container-inner"><div class="row"><div id="sp-menu" class="col-8 col-md-11 col-lg-11 "><div class="sp-column ts-menu"><nav class="sp-megamenu-wrapper" role="navigation"><a ondragstart="return false;" id="offcanvas-toggler" aria-label="Navigation" class="offcanvas-toggler-right d-block d-lg-none" href="#"><i class="fa fa-bars" aria-hidden="true" title="Navigation"></i></a><ul class="sp-megamenu-parent menu-animation-fade-up d-none d-lg-block"><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php">Home</a></li><li class="sp-menu-item sp-has-child active"><a ondragstart="return false;" href="/index.php/news">News</a><div class="sp-dropdown sp-dropdown-main sp-menu-right" style="width: 200px;"><div class="sp-dropdown-inner"><ul class="sp-dropdown-items"><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/news/nascar-cup-series-news">NASCAR Cup Series News</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/news/xfinity-series-news">Xfinity Series News</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/news/nascar-truck-series-news">NASCAR Truck Series News</a></li><li class="sp-menu-item current-item active"><a ondragstart="return false;" href="/index.php/news/speedway-news">Speedway News</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/news/racing-news">Racing News</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/news/eracing-news">eRacing News</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/news/latest-news">Latest News</a></li></ul></div></div></li><li class="sp-menu-item sp-has-child"><a ondragstart="return false;" href="/index.php/nascar-schedules">Schedules</a><div class="sp-dropdown sp-dropdown-main sp-menu-right" style="width: 200px;"><div class="sp-dropdown-inner"><ul class="sp-dropdown-items"><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/nascar-schedules/nascar-cup-series-schedule">NASCAR Cup Series Schedule</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/nascar-schedules/xfinity-series-schedule">Xfinity Series Schedule</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/nascar-schedules/nascar-truck-series-schedule">NASCAR Truck Series Schedule</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/nascar-schedules/weekend-schedule">Weekend Schedule</a></li></ul></div></div></li><li class="sp-menu-item sp-has-child"><a ondragstart="return false;" href="/index.php/point-standings">Point Standings</a><div class="sp-dropdown sp-dropdown-main sp-menu-right" style="width: 200px;"><div class="sp-dropdown-inner"><ul class="sp-dropdown-items"><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/point-standings/nascar-cup-series">NASCAR Cup Series</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/point-standings/xfinity-series">Xfinity Series</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/point-standings/nascar-truck-series">NASCAR Truck Series</a></li></ul></div></div></li><li class="sp-menu-item sp-has-child"><a ondragstart="return false;" href="/index.php/scanner-frequencies">Scanner Frequencies</a><div class="sp-dropdown sp-dropdown-main sp-menu-right" style="width: 200px;"><div class="sp-dropdown-inner"><ul class="sp-dropdown-items"><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/scanner-frequencies/nascar-cup-series-frequencies">NASCAR Cup Series Frequencies</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/scanner-frequencies/xfinity-frequencies">Xfinity Frequencies</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/scanner-frequencies/nascar-truck-series-frequencies">NASCAR Truck Series Frequencies</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/scanner-frequencies/arca-series-frequencies">ARCA Series Frequencies </a></li></ul></div></div></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/writers-wanted">Writers Wanted</a></li></ul></nav></div></div><div id="sp-search" class="col-lg-1 "><div class="sp-column "><div class="sp-module  ts-search"><div class="sp-module-content">
<div class="nav-search-icon">
<i class="icon icon-search"></i>
</div>
<div class="nav-search-form" style="display: none;">
<div class="search ts-search">
<form action="/index.php/news/speedway-news" method="post">
<input name="searchword" id="mod-search-searchword" maxlength="200" class="inputbox search-query" type="text" size="0" placeholder="Type and hit ENTER" /><span class="search-close">×</span> <input type="hidden" name="task" value="search" />
<input type="hidden" name="option" value="com_search" />
<input type="hidden" name="Itemid" value="190" />
</form>
</div>
</div></div></div></div></div></div></div></div></section><section id="sp-main-body"><div class="container"><div class="container-inner"><div class="row"><main id="sp-component" class="col-lg-8 " role="main"><div class="sp-column "><div id="system-message-container">
</div>

<span id="startOfPageId59396"></span>
<div id="k2Container" class="blog-details-content ts-content-box itemView">


<div class="itemHeader">

<h2 class="itemTitle">
Panella, Moles, Parreira and Maulding win Turkey Bowl XX features on Saturday at Delta
</h2>
</div>
<div class="ItemMetaInfo">

<span class="itemAuthor">
<a ondragstart="return false;" rel="author" href="/index.php/news/speedway-news/author/1069-speedwaydigeststaff">Speedway Digest Staff</a>
</span>

<div class="itemCategory">
<a ondragstart="return false;" href="/index.php/news/speedway-news">Speedway News</a>
</div>

<span class="itemDateCreated">
<i class="fa fa-clock-o"></i> Monday, Oct 26 </span>

<span class="itemHits">
<i class="icon-fire" aria-hidden="true"></i>
60 </span>
</div>


<div class="itemBody">



<div class="itemImageBlock">
<span class="itemImage">
<a ondragstart="return false;" data-k2-modal="image" href="/media/k2/items/cache/5c2ebf43c77043a0f15634f30ba303b2_XL.jpg" title="Click to preview image">
<img ondragstart="return false;" src="/media/k2/items/cache/5c2ebf43c77043a0f15634f30ba303b2_L.jpg" alt="Panella, Moles, Parreira and Maulding win Turkey Bowl XX features on Saturday at Delta" style="width:400px; height:auto;" />
</a>
</span>

<span class="itemImageCredits">Delta Speedway Photo</span>
<div class="clr"></div>
</div>

<div class="itemFullText">
<p><span style="font-size: 14px;"><span style="font-family: arial,helvetica neue,helvetica,sans-serif;">Stockton’s Alex Panella and Watsonville’s Rickey Sanders put on a thrilling show over the closing laps to help finish off the season at Delta Speedway on Saturday. In the end it was Panella prevailing at the checkered flag to scoop up the $2,000 grand prize with the Super 600s at Turkey Bowl XX. <br /> <br /> Raisin City, California’s Mitchell Moles performed a dominating drive to win the $2,000 feature for the Non-Wing division, while Hanford’s Dalton Parreira and Rancho Murieta’s Lucas Mauldin brought home $1,000 apiece by winning the Restricted and Junior Sprint main events respectively. <br /> <br /> The box score will show Panella captured the Super 600 A-main from the pole however, it was anything but easy for the driver of the Panella Trucking No. 12 machine. “It was a great race at the end with Rickey Sanders and I’m pumped to be standing up here right now,” he commented in victory lane. “I really don’t know what to say. I just can’t believe we pulled it off. It’s awesome to win the Turkey Bowl and I want to thank all of our sponsors and everyone that helps us out.” <br /> <br /> Panella had his way with things out front early in the 40-lapper but soon felt pressure in the form of Fresno’s Caden Steele, who ran the bottom side of the speedway to perfection. At one point Steele made a beautiful move to snag the lead in traffic, but a caution at that same time negated the pass. A well-prepared surface lent itself to some fantastic racing throughout the field with numerous sliders and bold moves taking place. <br /> <br /> As the laps wound down Sanders picked off cars and moved in on Panella in heavy duty lapped traffic. The duo proceeded to trade the lead numerous times with close slide jobs in every corner. At the checkered it was Panella narrowly beating out Sanders for the breathtaking victory. Nikko Panella came home in third with B-main winner and 17th starter Jake Hagopian in fourth. Steele rounded out the top-five. <br /> <br /> Opening night heat race wins for the Super 600s on Friday were claimed by Caeden Steele, Alex Panella and John Bordenave. Qualifying race wins went to Alex Panella, Nate Matherly and Caeden Steele. The Pole Shuffle went to Alex Panella. <br /> <br /> The Non-Wing feature was all about Mitchell Moles who checked out from the field and worked lapped traffic like a magician. The Micro stud captured the 40-lap finale by over 6 seconds to win the Turkey Bowl for the second consecutive season. Behind him though, the action was hot and heavy with Fresno’s Tyler Smith coming out on top of an excellent battle with Madero Ranchos driver Dalton Hill to earn a runner up finish. <br /> <br /> Hill crossed the stripe in third with Robbie Lewis and Brandon Carey completing the top-five. B-main wins during the night went to Katey Syra and Brody Petrie.  <br /> <br /> Non-Wing heat races on Friday were picked off by Robbie Lewis, Austin Stone, Joe Silva, Kyle Mentch and Tyler Smith. Qualifying races were claimed by Austin Stone, Mitchel Moles, Tyler Smith, Nikko Panella and Kyle Mentch. The Pole Shuffle was captured by Mitchel Moles. A total of 46 Non-Wing 600s competed at the Turkey Bowl. <br /> <br /> The 30-lap Restricted main event was a back and forth duel that ended with Dalton Parreira bringing home the big triumph. Tracy’s Brandon Riveira had battled his way to the lead at the halfway point but encountered issues that left him parked in the infield towards the waning circuits. After that Parreira ran smooth and consistent laps to cross the Tyler Carey checkered for the win. Colin Kirby came home in second, followed by Arizona racer Corbin Rueschenberg in third, 16th starter Austin Wood in fourth and Broedy Graham in fifth. <br /> <br /> Claiming Restricted heat races on opening night Friday were Dominic Carter, Destry Miller and Corbin Rueschenberg. Qualifying race victories were garnered by Teagan Moles, Colin Kirby and Dominic Carters. The Knock Out Race went to Reilee Phillips. <br /> <br /> Delta Speedway track champion Lucas Mauldin picked up a closely contested Junior Sprint victory on Saturday night. Mauldin felt heat from Manteca’s Brody Rubio over the duration of the 25 lapper, in what was an entertaining feature. At the line the official margin of victory for Mauldin over Rubio read as 0.185 seconds. Tracy’s Kyle Fernandez earned the final spot on the podium with Pleasanton’s Kellan Harper and Bakersfield’s Blayden Graham completing the top-five. <br /> <br /> Junior heat races on opening night Friday went to Kyle Fernandez, Brody Rubio, Lucas Mauldin and Jonathan Andrichuk. <br /> <br /> Delta Speedway presented by Financial Center Credit Union thanks Interstate Truck Center, Lovotti Air, Van De Pol Petroleum, Kludt Oil, Hoosier Racing Tire, Starr Property Management, Performance Electronics, Genova Bakery, Bruno's Peppers, Motion Media, and Panella Trucking for their support.</span></span></p>
<p><span style="font-size: 14px;">Delta Speedway PR</span></p> </div>
<div class="clr"></div>
<div class="itemToolbarContent">

<div class="itemRatingBlock">
<span>Rate this item</span>
<div class="itemRatingForm">
<ul class="itemRatingList">
<li class="itemCurrentRating" id="itemCurrentRating59396" style="width:0%;"></li>
<li><a ondragstart="return false;" href="#" data-id="59396" title="1 star out of 5" class="one-star">1</a></li>
<li><a ondragstart="return false;" href="#" data-id="59396" title="2 stars out of 5" class="two-stars">2</a></li>
<li><a ondragstart="return false;" href="#" data-id="59396" title="3 stars out of 5" class="three-stars">3</a></li>
<li><a ondragstart="return false;" href="#" data-id="59396" title="4 stars out of 5" class="four-stars">4</a></li>
<li><a ondragstart="return false;" href="#" data-id="59396" title="5 stars out of 5" class="five-stars">5</a></li>
</ul>
<div id="itemRatingLog59396" class="itemRatingLog">(0 votes)</div>
<div class="clr"></div>
</div>
<div class="clr"></div>
</div>
<div class="itemToolbar float-right">
<ul>

<li>
<span class="itemTextResizerTitle">font size</span>
<a ondragstart="return false;" href="#" id="fontDecrease">
<span>decrease font size</span>
</a>
<a ondragstart="return false;" href="#" id="fontIncrease">
<span>increase font size</span>
</a>
</li>

<li>
<a ondragstart="return false;" class="itemPrintLink" rel="nofollow" href="/index.php/news/speedway-news/59396-panella-moles-parreira-and-maulding-win-turkey-bowl-xx-features-on-saturday-at-delta?tmpl=component&amp;print=1" onclick="window.open(this.href,'printWindow','width=900,height=600,location=no,menubar=no,resizable=yes,scrollbars=yes'); return false;">
<span>Print</span>
</a>
</li>

<li>
<a ondragstart="return false;" class="itemEmailLink" rel="nofollow" href="/index.php/component/mailto/?tmpl=component&amp;template=ts_newslinen&amp;link=3202b50ffe2f473d812589692a7fd518d3bbdeaa" onclick="window.open(this.href,'emailWindow','width=400,height=350,location=no,menubar=no,resizable=no,scrollbars=no'); return false;">
<span>Email</span>
</a>
</li>
</ul>
<div class="clr"></div>
</div>
</div>
<div class="itemContentFooter">
<div class="clr"></div>
</div>


<div class="clr"></div>
</div>

<div class="itemSocialSharing">

<div class="itemTwitterButton">
<a ondragstart="return false;" href="https://twitter.com/share" class="twitter-share-button" data-lang="en-gb" data-via="">Tweet</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
</div>

<div class="itemFacebookButton">
<div id="fb-root"></div>
<script>(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(d.getElementById(id)) return;js=d.createElement(s);js.id=id;js.src="//connect.facebook.net/en_GB/sdk.js#xfbml=1&version=v2.5";fjs.parentNode.insertBefore(js,fjs);}(document,'script','facebook-jssdk'));</script>
<div class="fb-like" data-width="200" data-layout="button_count" data-action="like" data-show-faces="false" data-share="false"></div>
</div>
<div class="clr"></div>
</div>
<div class="itemLinks">
<div class="clr"></div>
</div>

<div class="itemNavigation">
<a ondragstart="return false;" class="itemPrevious" href="/index.php/news/speedway-news/59382-johnson-bowyer-honored-before-their-final-nascar-race-at-tms">&laquo; Johnson, Bowyer honored before their final NASCAR Race at TMS</a>
<a ondragstart="return false;" class="itemNext" href="/index.php/news/speedway-news/59398-large-turnout-of-cars-anticipated-for-this-weekend-s-all-american-400-events">Large Turnout Of Cars Anticipated For This Weekend's All American 400 Events &raquo;</a>
</div>

<div class="itemAuthorBlock">
<img ondragstart="return false;" class="itemAuthorAvatar" src="/media/k2/users/13.png" alt="Speedway Digest Staff" />
<div class="itemAuthorDetails">
<h3 class="itemAuthorName">
<a ondragstart="return false;" rel="author" href="/index.php/news/speedway-news/author/1069-speedwaydigeststaff">Speedway Digest Staff</a>
</h3>
<p><p>Follow us on Twitter <a ondragstart="return false;" href="https://www.twitter.com/speedwaydigest">@SpeedwayDigest</a></p></p>
<div class="clr"></div>

<div class="clr"></div>
</div>
<div class="clr"></div>
</div>

<div class="itemAuthorLatest">
<h3>Latest from Speedway Digest Staff</h3>
<ul>
<li class="even">
<a ondragstart="return false;" href="/index.php/news/nascar-truck-series-news/59401-jordan-anderson-s-race-to-freedom-ii-chevrolet-locked-and-loaded-for-martinsville-speedway">Jordan Anderson’s ‘Race to Freedom II’ Chevrolet Locked and Loaded for Martinsville Speedway</a>
</li>
<li class="odd">
<a ondragstart="return false;" href="/index.php/news/xfinity-series-news/59399-aj-allmendinger-and-nutrien-ag-solutions-team-up-for-martinsville-speedway">AJ Allmendinger and Nutrien Ag Solutions Team up for Martinsville Speedway</a>
</li>
<li class="even">
<a ondragstart="return false;" href="/index.php/news/speedway-news/59398-large-turnout-of-cars-anticipated-for-this-weekend-s-all-american-400-events">Large Turnout Of Cars Anticipated For This Weekend's All American 400 Events</a>
</li>
<li class="odd">
<a ondragstart="return false;" href="/index.php/news/nascar-cup-series-news/59397-rudy-fugle-named-crew-chief-for-william-byron-and-no-24-hendrick-motorsports-team">Rudy Fugle named crew chief for William Byron and No. 24 Hendrick Motorsports team</a>
</li>
<li class="even">
<a ondragstart="return false;" href="/index.php/news/racing-news/59395-indiana-native-hale-named-president-of-the-indianapolis-motor-speedway-museum">Indiana Native Hale Named President of the Indianapolis Motor Speedway Museum</a>
</li>
</ul>
<div class="clr"></div>
</div>
<div class="clr"></div>


<div class="itemBackToTop">
<a ondragstart="return false;" class="k2Anchor" href="/index.php/news/speedway-news/59396-panella-moles-parreira-and-maulding-win-turkey-bowl-xx-features-on-saturday-at-delta#startOfPageId59396">
back to top </a>
</div>
<div class="clr"></div>
</div>


</div></main><aside id="sp-right" class="col-lg-4 "><div class="sp-column "><div class="sp-module  ts-block-social-list title-bg"><h3 class="sp-module-title">Follow Us</h3><div class="sp-module-content">
<div id="sp_social205" class="sp_social icon_size_32  ts-block-social-list title-bg">
<ul>
<li class="rss">
<a ondragstart="return false;" target='_blank' title="RSS" href="https://speedwaydigest.com/index.php/news/latest-news?format=feed"><i class="fa fa-rss"></i>
<span class="ts-social-title">RSS</span>
<span class="ts-social-desc">Subscribe us on News</span></a></li>
</a></li>
<li class="facebook"><a ondragstart="return false;" target='_blank' title="Facebook" href="https://www.facebook.com/speedwaydigest"><i class="fa fa-facebook"> </i>
<span class="ts-social-title">Facebook</span>
<span class="ts-social-desc">Like us on Facebook</span></a></li>
<li class="twitter"><a ondragstart="return false;" target='_blank' title="Twitter" href="https://www.twitter.com/speedwaydigest"><i class="fa fa-twitter"></i>
<span class="ts-social-title">Twitter</span>
<span class="ts-social-desc">Follow us on Twitter</span></a></li>
<li class="youtube"><a ondragstart="return false;" target='_blank' title="YouTube" href="https://www.youtube.com/channel/UCEHcjt3lx140xojhPUEYZ0A"><i class="fa fa-youtube"></i>
<span class="ts-social-title">Youtube</span>
<span class="ts-social-desc">Subscribe on Youtube</span></a></li>
</a></li>
</ul>
<div style="clear:both"></div>
</div></div></div><div class="sp-module "><div class="sp-module-content">
<div class="custom">
<center><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-4983971213106691" data-ad-slot="1381625561" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
<br><br>
<div id="sas_71427"></div>
<script type="application/javascript">
    sas.cmd.push(function() {
        sas.render("71427");  // Format : 300x250_RON 300x250
    });
</script>
</center></div>
</div></div><div class="sp-module "><div class="sp-module-content">
<div class="custom">
<center><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-4983971213106691" data-ad-slot="1381625561" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></center></div>
</div></div></div></aside></div></div></div></section><footer id="sp-footer" class="ts-footer"><div class="row"><div id="sp-footer1" class="col-lg-6 "><div class="sp-column text-center"><span class="sp-copyright">Copyright © 2010 - 2020 STS Motorsports Inc. All Rights Reserved.</span></div></div><div id="sp-footer2" class="col-lg-6 "><div class="sp-column "><div class="sp-module "><div class="sp-module-content"><ul class="menu nav-pills">
<li class="item-1557"><a ondragstart="return false;" href="/index.php/advertise">Advertise</a></li><li class="item-1559"><a ondragstart="return false;" href="/index.php/privacy-policy">Privacy Policy</a></li><li class="item-1621"><a ondragstart="return false;" href="/index.php/sitemap">Sitemap</a></li><li class="item-1558"><a ondragstart="return false;" href="/index.php/sd-staff">SD Staff</a></li><li class="item-1576"><a ondragstart="return false;" href="/index.php/writer-login">Writer Login</a></li></ul>
</div></div></div></div></div></footer> </div>
</div>

<div class="offcanvas-overlay"></div>
<div class="offcanvas-menu">
<a ondragstart="return false;" href="#" class="close-offcanvas"><span class="fa fa-remove"></span></a>
<div class="offcanvas-inner">
<div class="sp-module "><div class="sp-module-content"><ul class="menu">
<li class="item-241 default"><a ondragstart="return false;" href="/index.php">Home</a></li><li class="item-186 active menu-deeper menu-parent"><a ondragstart="return false;" href="/index.php/news">News<span class="menu-toggler"></span></a><ul class="menu-child"><li class="item-205"><a ondragstart="return false;" href="/index.php/news/nascar-cup-series-news">NASCAR Cup Series News</a></li><li class="item-188"><a ondragstart="return false;" href="/index.php/news/xfinity-series-news">Xfinity Series News</a></li><li class="item-1922"><a ondragstart="return false;" href="/index.php/news/nascar-truck-series-news">NASCAR Truck Series News</a></li><li class="item-190 current active"><a ondragstart="return false;" href="/index.php/news/speedway-news">Speedway News</a></li><li class="item-207"><a ondragstart="return false;" href="/index.php/news/racing-news">Racing News</a></li><li class="item-2153"><a ondragstart="return false;" href="/index.php/news/eracing-news">eRacing News</a></li><li class="item-1876"><a ondragstart="return false;" href="/index.php/news/latest-news">Latest News</a></li></ul></li><li class="item-197 menu-deeper menu-parent"><a ondragstart="return false;" href="/index.php/nascar-schedules">Schedules<span class="menu-toggler"></span></a><ul class="menu-child"><li class="item-198"><a ondragstart="return false;" href="/index.php/nascar-schedules/nascar-cup-series-schedule">NASCAR Cup Series Schedule</a></li><li class="item-199"><a ondragstart="return false;" href="/index.php/nascar-schedules/xfinity-series-schedule">Xfinity Series Schedule</a></li><li class="item-200"><a ondragstart="return false;" href="/index.php/nascar-schedules/nascar-truck-series-schedule">NASCAR Truck Series Schedule</a></li><li class="item-202"><a ondragstart="return false;" href="/index.php/nascar-schedules/weekend-schedule">Weekend Schedule</a></li></ul></li><li class="item-208 menu-deeper menu-parent"><a ondragstart="return false;" href="/index.php/point-standings">Point Standings<span class="menu-toggler"></span></a><ul class="menu-child"><li class="item-209"><a ondragstart="return false;" href="/index.php/point-standings/nascar-cup-series">NASCAR Cup Series</a></li><li class="item-210"><a ondragstart="return false;" href="/index.php/point-standings/xfinity-series">Xfinity Series</a></li><li class="item-211"><a ondragstart="return false;" href="/index.php/point-standings/nascar-truck-series">NASCAR Truck Series</a></li></ul></li><li class="item-204 menu-deeper menu-parent"><a ondragstart="return false;" href="/index.php/scanner-frequencies">Scanner Frequencies<span class="menu-toggler"></span></a><ul class="menu-child"><li class="item-235"><a ondragstart="return false;" href="/index.php/scanner-frequencies/nascar-cup-series-frequencies">NASCAR Cup Series Frequencies</a></li><li class="item-236"><a ondragstart="return false;" href="/index.php/scanner-frequencies/xfinity-frequencies">Xfinity Frequencies</a></li><li class="item-237"><a ondragstart="return false;" href="/index.php/scanner-frequencies/nascar-truck-series-frequencies">NASCAR Truck Series Frequencies</a></li><li class="item-1596"><a ondragstart="return false;" href="/index.php/scanner-frequencies/arca-series-frequencies">ARCA Series Frequencies </a></li></ul></li><li class="item-606"><a ondragstart="return false;" href="/index.php/writers-wanted">Writers Wanted</a></li></ul>
</div></div>
</div>
</div>

<a ondragstart="return false;" href="#" class="sp-scroll-up" aria-label="Scroll Up"><span class="fa fa-chevron-up" aria-hidden="true"></span></a>

<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-DLpLH67QrYURU"
});
</script>
<noscript>
<div style="display:none;">
<img ondragstart="return false;" src="//pixel.quantserve.com/pixel/p-DLpLH67QrYURU.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>

<div id="openModal" class="modalDialog">
<div>
<a ondragstart="return false;" href="#close" title="Close" id="close" class="close">X</a>
<h2>No right click</h2>
<p>Please link the article. </p>
</div>
</div>
<script type="text/javascript">
	disableSelection(document.body)
</script>
</body>
</html>