<!doctype html><html prefix="og: http://ogp.me/ns#" lang="en-gb" dir="ltr"><head><meta charset="utf-8"><meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no"><link rel="canonical" href="https://speedwaydigest.com/index.php/news/xfinity-series-news/66013-daniel-hemric-bags-xfinity-championship-with-first-nascar-national-series-win"><base href="https://speedwaydigest.com/index.php/news/xfinity-series-news/66013-daniel-hemric-bags-xfinity-championship-with-first-nascar-national-series-win" /><meta http-equiv="content-type" content="text/html; charset=utf-8" /><meta name="keywords" content="NASCAR, NASCAR News, NASCAR Drivers, NASCAR Frequencies, NASCAR Cup Series, Monster Cup, XFINITY, Xfinity Series, Camping World, Camping World Truck Series, NASCAR Points, Speedway Digest, Speedway Digest NASCAR News, Daytona, Richmond, Martinsville, Dover, Charlotte, Darlington, North Wilkesboro, Texas Motor Speedway, Pocono Speedway, Watkins Glen, Auto Club Speedway, Bristol Motor Speedway, Kansas Speedway, Talladega Superspeedway, Atlanta Motor Speedway, News, Jimmie Johnson, Roush Racing, Hendricks Motorsports, BK Racing, Wood Brothers Racing, Richard Petty Motorsports, Yates Racing, Robert Yates Racing, Michael Waltrip Racing, Carl Edwards, Trevor Bayne, Save The Speedway, North Wilkesboro Speedway, Dale Earnhardt, Dale Earnhardt Jr., NASCAR Frequencies, Monster Energy NASCAR Cup Series, Monster Energy Series, XFINITY Series, Camping World Truck Series, Las Vegas Motor Speedway, Phoenix International Raceway, Charlotte Motor Speedway, New Hampshire Motor Speedway, Gateway Motorsports Park, Darlington Raceway, Ryan Blaney, Chase Elliott, Ford Performance, Team Chevy, Toyota Racing, Kyle Busch, Kurt Busch, Denny Hamlin, NASCAR schedule, nascar race today, nascar race schedule, nascar race results, nascar race this weekend, nascar race results today, nascar truck race, nascar trucks, where is the nascar race today, nascar xfinity race, nascar schedule, nascar news, daytona 500, nascar race today, nascar today, nascar race, nascar results, nascar race schedule, nascar live, race scanner, racing scanner, race scanners" /><meta name="rights" content="Copyright - Steven B. Wilson - STS Motorsports Inc. 2005 - 2021" /><meta name="author" content="Reid Spencer - NASCAR Wire Service" /><meta property="og:url" content="https://speedwaydigest.com/index.php/news/xfinity-series-news/66013-daniel-hemric-bags-xfinity-championship-with-first-nascar-national-series-win" /><meta property="og:type" content="article" /><meta property="og:title" content="Daniel Hemric bags Xfinity championship with first NASCAR national series win" /><meta property="og:description" content="Daniel Hemric picked the perfect time to win his first NASCAR national series race—and a title came with it. Executing an aggressive bump-and-run in Saturday night’s NASCAR Xfinity Series Championship Race, Hemric passed Austin Cindric in the final two corners at Phoenix Raceway. Approaching the fin..." /><meta property="og:image" content="https://www.speedwaydigest.com/media/k2/items/cache/046bf832cf98539a60cdf89fd70db733_M.jpg" /><meta name="image" content="https://www.speedwaydigest.com/media/k2/items/cache/046bf832cf98539a60cdf89fd70db733_M.jpg" /><meta name="twitter:card" content="summary" /><meta name="twitter:title" content="Daniel Hemric bags Xfinity championship with first NASCAR national series win" /><meta name="twitter:description" content="Daniel Hemric picked the perfect time to win his first NASCAR national series race—and a title came with it. Executing an aggressive bump-and-run in Saturday night’s NASCAR Xfinity Series Championship..." /><meta name="twitter:image" content="https://www.speedwaydigest.com/media/k2/items/cache/046bf832cf98539a60cdf89fd70db733_M.jpg" /><meta name="twitter:image:alt" content="Daniel Hemric bags Xfinity championship with first NASCAR national series win" /><meta name="description" content="Daniel Hemric picked the perfect time to win his first NASCAR national series race—and a title came with it. Executing an aggressive bump-and-run in S..." /><meta name="generator" content="Helix Ultimate - The Most Popular Joomla! Template Framework." /><title>Daniel Hemric bags Xfinity championship with first NASCAR national series win</title><link href="/index.php/news/xfinity-series-news/66013-daniel-hemric-bags-xfinity-championship-with-first-nascar-national-series-win" rel="canonical" /><link href="https://speedwaydigest.com/index.php/news/xfinity-series-news/66013-daniel-hemric-bags-xfinity-championship-with-first-nascar-national-series-win/amp" rel="amphtml" /><link href="/images/favicon.ico" rel="shortcut icon" type="image/vnd.microsoft.icon" /><link href="/favicon.ico" rel="shortcut icon" type="image/vnd.microsoft.icon" /> <script type="application/json" class="joomla-script-options new">{"data":{"breakpoints":{"tablet":991,"mobile":480},"header":{"stickyOffset":"100"}},"csrf.token":"78b86e9e1c563420f4ace7cf82ae91fe","system.paths":{"root":"","base":""}}</script> <script type="application/ld+json">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</script><meta http-equiv="imagetoolbar" content="no"><link rel="preload" as="style" href="/media/com_jchoptimize/cache/css/ee58665b34885653258d87a3847baef5.css" onload="this.rel='stylesheet'" /><style id="jch-optimize-critical-css">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</style> <script src="/media/com_jchoptimize/cache/js/baa4ea6143c38c7e0e06d2d836304d80.js"></script> <script async custom-element="amp-ad" src="https://cdn.ampproject.org/v0/amp-ad-0.1.js"></script> <script src="/media/com_jchoptimize/cache/js/8fa61ad7769d5879d4a98ad7777dcdf9.js"></script><noscript><style type="text/css">img.jch-lazyload,iframe.jch-lazyload{display:none}</style> </noscript> </head><body class="site helix-ultimate hu com-k2 view-item layout-default task-none itemid-188 en-gb ltr sticky-header layout-boxed offcanvas-init offcanvs-position-right"><div class="body-wrapper"><div class="body-innerwrapper"><section id="sp-top-bar" class="ts-top-bar-classic d-none d-sm-none d-md-block"><div class="container"><div class="container-inner"><div class="row"><div id="sp-top1" class="col-lg-2 "><div class="sp-column "><div class="sp-module "><div class="sp-module-content"><div id="ts_date155" class="ts_date_area "> <i class="fa fa-calendar-check-o"> </i> Sunday, Nov 07</div></div></div></div></div><div id="sp-top-menu" class="col-lg-3  d-md-none d-lg-block"><div class="sp-column "></div></div><div id="sp-top3" class="col-lg-7 "><div class="sp-column ts-top-social text-right"><ul class="social-icons"><li class="social-icon-facebook"><a ondragstart="return false;" target="_blank" href="https://www.facebook.com/speedwaydigest" aria-label="facebook"><span class="fa fa-facebook" aria-hidden="true"></span></a></li><li class="social-icon-twitter"><a ondragstart="return false;" target="_blank" href="https://www.twitter.com/speedwaydigest" aria-label="twitter"><span class="fa fa-twitter" aria-hidden="true"></span></a></li><li class="social-icon-pinterest"><a ondragstart="return false;" target="_blank" href="https://www.pinterest.com/speedwaydigest/" aria-label="Pinterest"><span class="fa fa-pinterest" aria-hidden="true"></span></a></li><li><a ondragstart="return false;" target="_blank" href="https://www.youtube.com/channel/UCEHcjt3lx140xojhPUEYZ0A" aria-label="Youtube"><span class="fa fa-youtube" aria-hidden="true"></span></a></li></ul></div></div></div></div></div></section><section id="sp-logo-area"><div class="container"><div class="container-inner"><div class="row"><div id="sp-logo" class="col-md-4 col-lg-3 "><div class="sp-column "><div class="logo"><a ondragstart="return false;" href="/"><img ondragstart="return false;" class="logo-image d-none d-lg-inline-block" src="/images/sdlogoweb.fw.png" alt="Speedway Digest - Home for NASCAR News"><img ondragstart="return false;" class="logo-image-phone d-inline-block d-lg-none" src="/images/sdlogoweb.fw.png" alt="Speedway Digest - Home for NASCAR News"></a></div></div></div><div id="sp-top-banner-2" class="col-md-8 col-lg-9 d-none d-sm-none d-md-block"><div class="sp-column "><div class="sp-module "><div class="sp-module-content"><div class="custom"> <script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-4983971213106691" data-ad-slot="7293211960" data-ad-format="auto"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div></div></div></div></div></div></div></div></section><section id="sp-menu" class="ts-nav-box"><div class="container"><div class="container-inner"><div class="row"><div id="sp-menu" class="col-8 col-md-11 col-lg-12 "><div class="sp-column ts-menu"><nav class="sp-megamenu-wrapper" role="navigation"><a ondragstart="return false;" id="offcanvas-toggler" aria-label="Navigation" class="offcanvas-toggler-right d-block d-lg-none" href="#"><i class="fa fa-bars" aria-hidden="true" title="Navigation"></i></a><ul class="sp-megamenu-parent menu-animation-fade-up d-none d-lg-block"><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php">Home</a></li><li class="sp-menu-item sp-has-child active"><a ondragstart="return false;" href="/index.php/news">News</a><div class="sp-dropdown sp-dropdown-main sp-menu-right" style="width: 200px;"><div class="sp-dropdown-inner"><ul class="sp-dropdown-items"><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/news/nascar-cup-series-news">NASCAR Cup Series News</a></li><li class="sp-menu-item current-item active"><a ondragstart="return false;" aria-current="page" href="/index.php/news/xfinity-series-news">Xfinity Series News</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/news/nascar-truck-series-news">NASCAR Truck Series News</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/news/speedway-news">Speedway News</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/news/racing-news">Racing News</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/news/eracing-news">eRacing News</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/news/latest-news">Latest News</a></li></ul></div></div></li><li class="sp-menu-item sp-has-child"><a ondragstart="return false;" href="/index.php/nascar-schedules">Schedules</a><div class="sp-dropdown sp-dropdown-main sp-menu-right" style="width: 200px;"><div class="sp-dropdown-inner"><ul class="sp-dropdown-items"><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/nascar-schedules/nascar-cup-series-schedule">NASCAR Cup Series Schedule</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/nascar-schedules/xfinity-series-schedule">Xfinity Series Schedule</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/nascar-schedules/nascar-truck-series-schedule">NASCAR Truck Series Schedule</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/nascar-schedules/weekend-schedule">Weekend Schedule</a></li></ul></div></div></li><li class="sp-menu-item sp-has-child"><a ondragstart="return false;" href="/index.php/point-standings">Point Standings</a><div class="sp-dropdown sp-dropdown-main sp-menu-right" style="width: 200px;"><div class="sp-dropdown-inner"><ul class="sp-dropdown-items"><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/point-standings/nascar-cup-series">NASCAR Cup Series</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/point-standings/xfinity-series">Xfinity Series</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/point-standings/nascar-truck-series">NASCAR Truck Series</a></li></ul></div></div></li><li class="sp-menu-item sp-has-child"><a ondragstart="return false;" href="/index.php/scanner-frequencies">Scanner Frequencies</a><div class="sp-dropdown sp-dropdown-main sp-menu-right" style="width: 200px;"><div class="sp-dropdown-inner"><ul class="sp-dropdown-items"><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/scanner-frequencies/nascar-cup-series-frequencies">NASCAR Cup Series Frequencies</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/scanner-frequencies/xfinity-frequencies">Xfinity Frequencies</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/scanner-frequencies/nascar-truck-series-frequencies">NASCAR Truck Series Frequencies</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/scanner-frequencies/arca-series-frequencies">ARCA Series Frequencies </a></li></ul></div></div></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/writers-wanted">Writers Wanted</a></li></ul></nav></div></div></div></div></div></section><section id="sp-main-body"><div class="container"><div class="container-inner"><div class="row"> <main id="sp-component" class="col-lg-8 "><div class="sp-column "><div id="system-message-container"> </div> <span id="startOfPageId66013"></span> <div id="k2Container" class="blog-details-content ts-content-box itemView"><div class="itemHeader"><h2 class="itemTitle"> Daniel Hemric bags Xfinity championship with first NASCAR national series win </h2></div><div class="ItemMetaInfo"> <span class="itemAuthor"> Reid Spencer - NASCAR Wire Service </span> <div class="itemCategory"> <a ondragstart="return false;" href="/index.php/news/xfinity-series-news">Xfinity Series News</a> </div> <span class="itemDateCreated"> <i class="fa fa-clock-o"></i> Sunday, Nov 07 </span> <span class="itemHits"> <i class="icon-fire" aria-hidden="true"></i> 34 </span> </div><div class="itemBody"><div class="itemImageBlock"> <span class="itemImage"> <a ondragstart="return false;" data-k2-modal="image" href="/media/k2/items/cache/046bf832cf98539a60cdf89fd70db733_XL.jpg" title="Click to preview image"> <img class="jch-lazyload" ondragstart="return false;" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxIiBoZWlnaHQ9IjEiPjwvc3ZnPg==" data-src="/media/k2/items/cache/046bf832cf98539a60cdf89fd70db733_L.jpg" alt="Daniel Hemric bags Xfinity championship with first NASCAR national series win" style="width:400px; height:auto;" /><noscript><img ondragstart="return false;" src="/media/k2/items/cache/046bf832cf98539a60cdf89fd70db733_L.jpg" alt="Daniel Hemric bags Xfinity championship with first NASCAR national series win" style="width:400px; height:auto;" /></noscript></a> </span> <span class="itemImageCredits">NK Photography Photo</span> <div class="clr"></div></div><div class="itemFullText"><p>Daniel Hemric picked the perfect time to win his first NASCAR national series race—and a title came with it.</p><p>Executing an aggressive bump-and-run in Saturday night’s NASCAR Xfinity Series Championship Race, Hemric passed Austin Cindric in the final two corners at Phoenix Raceway.</p><p>Approaching the finish line, the cars collided side-to-side, with Hemric crossing the stripe .030 seconds ahead of Cindric—roughly five feet—denying the driver of the No. 22 Team Penske Ford a second straight championship.</p><p>The victory came in Hemric’s 208th NASCAR national series start, silencing critics who kept asking, “Will Hemric ever win a race?”</p><p>The answer came from crew chief Dave Rogers moments after the winning driver crossed the stripe and clinched the title.</p><p>“How about that, champion?” Rogers said. “You’ll never have to hear that stupid question again.”</p><p>“Never again!” Hemric shouted in reply.</p><p>Hemric, who is leaving the No. 18 Joe Gibbs Racing Toyota in favor of a ride with Kaulig Racing next year, was unapologetic about moving Cindric’s Ford up the track to win the race at the end of a two-lap overtime that extended the event from 200 to 204 laps.</p><p>“I'm blacked out, blacked out,” Hemric said at the start/finish line after turning a back flip off the roof of his car. “Just knew I had to be the first one to the line. I thought I let him get too much of a run off of (Turn) 4 (on the first lap of overtime).</p><p>“Drove into (Turn) 1, knew I was close, not to completely use them up, but we work our asses off for an opportunity like this—excuse my language. This is what it's all about, winning at the second highest level in all of motorsports. What an honor…</p><p>“How about those race fans? That back flip good enough for you? I’ve been waiting a long damn time to do that.”</p><p>Cindric took the loss with consummate grace. </p><p>“Until you spin somebody out, it’s not dirty racing,” said Cindric, who entered the championship event with five wins to his credit this season. “If everyone in the stands enjoyed it, it's good racing. </p><p>“I'm appreciative of the opportunity to race on such a big stage, race for Roger Penske, represent Ford Performance, all of our sponsors that helped us this season. It would have been awesome to finish this out. I felt like we had a dominant race car, felt like we did everything right. Come up a little short.”</p><p>As a consolation prize, Cindric secured the Xfinity Series Owners Championship for Roger Penske with his runner-up result.</p><p>The other two Championship 4 drivers—Noah Gragson and AJ Allmendinger—were in contention at the end. Gragson slammed the wall shortly after a restart on Lap 193 and fell to 12th at the finish.</p><p>Allmendinger suffered a loose wheel late in the race and spun in Turn 2 on Lap 181, causing the eighth of 10 cautions. Cindric, who led a race-high 113 laps, had a commanding lead at the time, but the yellow bunched the field and set up the late-race shootout.</p><p>Harrison Burton ran third on Saturday, followed by Riley Herbst and Justin Haley. John Hunter Nemechek, Brandon Jones, Brett Moffitt, Justin Allgaier and Sheldon Creed completed the top 10.</p></div><div class="clr"></div><div class="itemToolbarContent"><div class="itemRatingBlock"> <span>Rate this item</span> <div class="itemRatingForm"><ul class="itemRatingList"> <li class="itemCurrentRating" id="itemCurrentRating66013" style="width:0%;"></li> <li><a ondragstart="return false;" href="#" data-id="66013" title="1 star out of 5" class="one-star">1</a></li> <li><a ondragstart="return false;" href="#" data-id="66013" title="2 stars out of 5" class="two-stars">2</a></li> <li><a ondragstart="return false;" href="#" data-id="66013" title="3 stars out of 5" class="three-stars">3</a></li> <li><a ondragstart="return false;" href="#" data-id="66013" title="4 stars out of 5" class="four-stars">4</a></li> <li><a ondragstart="return false;" href="#" data-id="66013" title="5 stars out of 5" class="five-stars">5</a></li> </ul><div id="itemRatingLog66013" class="itemRatingLog">(0 votes)</div><div class="clr"></div></div><div class="clr"></div></div><div class="itemToolbar float-right"><ul> <li> <span class="itemTextResizerTitle">font size</span> <a ondragstart="return false;" href="#" id="fontDecrease"> <span>decrease font size</span> </a> <a ondragstart="return false;" href="#" id="fontIncrease"> <span>increase font size</span> </a> </li> <li> <a ondragstart="return false;" class="itemPrintLink" rel="nofollow" href="/index.php/news/xfinity-series-news/66013-daniel-hemric-bags-xfinity-championship-with-first-nascar-national-series-win?tmpl=component&amp;print=1" onclick="window.open(this.href,'printWindow','width=900,height=600,location=no,menubar=no,resizable=yes,scrollbars=yes'); return false;"> <span>Print</span> </a> </li> <li> <a ondragstart="return false;" class="itemEmailLink" rel="nofollow" href="/index.php/component/mailto/?tmpl=component&amp;template=ts_newslinen&amp;link=009664ed4f7c5528f521dad43c882aae68d169c9" onclick="window.open(this.href,'emailWindow','width=400,height=350,location=no,menubar=no,resizable=no,scrollbars=no'); return false;"> <span>Email</span> </a> </li> </ul><div class="clr"></div></div></div><div class="itemContentFooter"><div class="clr"></div></div><div class="clr"></div></div><div class="itemSocialSharing"><div class="itemTwitterButton"> <a ondragstart="return false;" href="https://twitter.com/share" class="twitter-share-button" data-lang="en-gb" data-via="">Tweet</a> <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document,'script','twitter-wjs');</script> </div><div class="itemFacebookButton"><div id="fb-root"></div> <script>(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(d.getElementById(id))return;js=d.createElement(s);js.id=id;js.src="//connect.facebook.net/en_GB/sdk.js#xfbml=1&version=v2.5";fjs.parentNode.insertBefore(js,fjs);}(document,'script','facebook-jssdk'));</script><div class="fb-like" data-width="200" data-layout="button_count" data-action="like" data-show-faces="false" data-share="false"></div></div><div class="clr"></div></div><div class="itemLinks"><div class="clr"></div></div><div class="itemNavigation"> <a ondragstart="return false;" class="itemPrevious" href="/index.php/news/xfinity-series-news/66012-rcr-nxs-post-race-report-phoenix-raceway">&laquo; RCR NXS Post Race Report - Phoenix Raceway</a> <a ondragstart="return false;" class="itemNext" href="/index.php/news/xfinity-series-news/66014-herbst-scores-strong-fourth-at-phoenix">Herbst Scores Strong Fourth at Phoenix &raquo;</a> </div><div class="clr"></div><div class="itemBackToTop"> <a ondragstart="return false;" class="k2Anchor" href="/index.php/news/xfinity-series-news/66013-daniel-hemric-bags-xfinity-championship-with-first-nascar-national-series-win#startOfPageId66013"> back to top </a> </div><div class="clr"></div></div></div></main><aside id="sp-right" class="col-lg-4 "><div class="sp-column "><div class="sp-module "><div class="sp-module-content"><div class="custom"> <center><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-4983971213106691" data-ad-slot="1381625561" data-ad-format="auto" data-full-width-responsive="true"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></center></div></div></div><div class="sp-module "><div class="sp-module-content"><div class="custom"> <center><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-4983971213106691" data-ad-slot="1381625561" data-ad-format="auto" data-full-width-responsive="true"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></center></div></div></div></div></aside></div></div></div></section><footer id="sp-footer" class="ts-footer"><div class="row"><div id="sp-footer1" class="col-lg-6 "><div class="sp-column text-center"><span class="sp-copyright">Copyright © 2010 - 2021 STS Motorsports Inc. All Rights Reserved.</span></div></div><div id="sp-footer2" class="col-lg-6 "><div class="sp-column "><div class="sp-module "><div class="sp-module-content"><ul class="menu nav-pills"> <li class="item-1557"><a ondragstart="return false;" href="/index.php/advertise">Advertise</a></li><li class="item-1559"><a ondragstart="return false;" href="/index.php/privacy-policy">Privacy Policy</a></li><li class="item-1621"><a ondragstart="return false;" href="/index.php/sitemap">Sitemap</a></li><li class="item-1558"><a ondragstart="return false;" href="/index.php/sd-staff">SD Staff</a></li><li class="item-1576"><a ondragstart="return false;" href="/index.php/writer-login">Writer Login</a></li></ul></div></div></div></div></div></footer></div></div><div class="offcanvas-overlay"></div><div class="offcanvas-menu"> <a ondragstart="return false;" href="#" class="close-offcanvas"><span class="fa fa-remove"></span></a> <div class="offcanvas-inner"><div class="sp-module "><div class="sp-module-content"><ul class="menu"> <li class="item-241 default"><a ondragstart="return false;" href="/index.php">Home</a></li><li class="item-186 active menu-deeper menu-parent"><a ondragstart="return false;" href="/index.php/news">News<span class="menu-toggler"></span></a><ul class="menu-child"><li class="item-205"><a ondragstart="return false;" href="/index.php/news/nascar-cup-series-news">NASCAR Cup Series News</a></li><li class="item-188 current active"><a ondragstart="return false;" href="/index.php/news/xfinity-series-news">Xfinity Series News</a></li><li class="item-1922"><a ondragstart="return false;" href="/index.php/news/nascar-truck-series-news">NASCAR Truck Series News</a></li><li class="item-190"><a ondragstart="return false;" href="/index.php/news/speedway-news">Speedway News</a></li><li class="item-207"><a ondragstart="return false;" href="/index.php/news/racing-news">Racing News</a></li><li class="item-2153"><a ondragstart="return false;" href="/index.php/news/eracing-news">eRacing News</a></li><li class="item-1876"><a ondragstart="return false;" href="/index.php/news/latest-news">Latest News</a></li></ul></li><li class="item-197 menu-deeper menu-parent"><a ondragstart="return false;" href="/index.php/nascar-schedules">Schedules<span class="menu-toggler"></span></a><ul class="menu-child"><li class="item-198"><a ondragstart="return false;" href="/index.php/nascar-schedules/nascar-cup-series-schedule">NASCAR Cup Series Schedule</a></li><li class="item-199"><a ondragstart="return false;" href="/index.php/nascar-schedules/xfinity-series-schedule">Xfinity Series Schedule</a></li><li class="item-200"><a ondragstart="return false;" href="/index.php/nascar-schedules/nascar-truck-series-schedule">NASCAR Truck Series Schedule</a></li><li class="item-202"><a ondragstart="return false;" href="/index.php/nascar-schedules/weekend-schedule">Weekend Schedule</a></li></ul></li><li class="item-208 menu-deeper menu-parent"><a ondragstart="return false;" href="/index.php/point-standings">Point Standings<span class="menu-toggler"></span></a><ul class="menu-child"><li class="item-209"><a ondragstart="return false;" href="/index.php/point-standings/nascar-cup-series">NASCAR Cup Series</a></li><li class="item-210"><a ondragstart="return false;" href="/index.php/point-standings/xfinity-series">Xfinity Series</a></li><li class="item-211"><a ondragstart="return false;" href="/index.php/point-standings/nascar-truck-series">NASCAR Truck Series</a></li></ul></li><li class="item-204 menu-deeper menu-parent"><a ondragstart="return false;" href="/index.php/scanner-frequencies">Scanner Frequencies<span class="menu-toggler"></span></a><ul class="menu-child"><li class="item-235"><a ondragstart="return false;" href="/index.php/scanner-frequencies/nascar-cup-series-frequencies">NASCAR Cup Series Frequencies</a></li><li class="item-236"><a ondragstart="return false;" href="/index.php/scanner-frequencies/xfinity-frequencies">Xfinity Frequencies</a></li><li class="item-237"><a ondragstart="return false;" href="/index.php/scanner-frequencies/nascar-truck-series-frequencies">NASCAR Truck Series Frequencies</a></li><li class="item-1596"><a ondragstart="return false;" href="/index.php/scanner-frequencies/arca-series-frequencies">ARCA Series Frequencies </a></li></ul></li><li class="item-606"><a ondragstart="return false;" href="/index.php/writers-wanted">Writers Wanted</a></li></ul></div></div></div></div> <a ondragstart="return false;" href="#" class="sp-scroll-up" aria-label="Scroll Up"><span class="fa fa-chevron-up" aria-hidden="true"></span></a> <amp-ad width="100vw" height="320" type="adsense" data-ad-client="ca-pub-4983971213106691" data-ad-slot="1381625561" data-auto-format="rspv" data-full-width=""><div overflow=""></div></amp-ad><div id="openModal" class="modalDialog"><div> <a ondragstart="return false;" href="#close" title="Close" id="close" class="close">X</a> <h2>No right click</h2><p>Please link the article. </p></div></div> <script type="text/javascript">disableSelection(document.body)</script> </body> </html>