<!doctype html><html prefix="og: http://ogp.me/ns#" lang="en-gb" dir="ltr"><head><meta charset="utf-8"><meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no"><link rel="canonical" href="https://speedwaydigest.com/index.php/news/racing-news/73886-2023-calendar-nascar-whelen-euro-series-set-for-historical-season"><base href="https://speedwaydigest.com/index.php/news/racing-news/73886-2023-calendar-nascar-whelen-euro-series-set-for-historical-season" /><meta http-equiv="content-type" content="text/html; charset=utf-8" /><meta name="keywords" content="NASCAR, NASCAR News, NASCAR Drivers, NASCAR Frequencies, NASCAR Cup Series, Monster Cup, XFINITY, Xfinity Series, Camping World, Camping World Truck Series, NASCAR Points, Speedway Digest, Speedway Digest NASCAR News, Daytona, Richmond, Martinsville, Dover, Charlotte, Darlington, North Wilkesboro, Texas Motor Speedway, Pocono Speedway, Watkins Glen, Auto Club Speedway, Bristol Motor Speedway, Kansas Speedway, Talladega Superspeedway, Atlanta Motor Speedway, News, Jimmie Johnson, Roush Racing, Hendricks Motorsports, BK Racing, Wood Brothers Racing, Richard Petty Motorsports, Yates Racing, Robert Yates Racing, Michael Waltrip Racing, Carl Edwards, Trevor Bayne, Save The Speedway, North Wilkesboro Speedway, Dale Earnhardt, Dale Earnhardt Jr., NASCAR Frequencies, Monster Energy NASCAR Cup Series, Monster Energy Series, XFINITY Series, Camping World Truck Series, Las Vegas Motor Speedway, Phoenix International Raceway, Charlotte Motor Speedway, New Hampshire Motor Speedway, Gateway Motorsports Park, Darlington Raceway, Ryan Blaney, Chase Elliott, Ford Performance, Team Chevy, Toyota Racing, Kyle Busch, Kurt Busch, Denny Hamlin, NASCAR schedule, nascar race today, nascar race schedule, nascar race results, nascar race this weekend, nascar race results today, nascar truck race, nascar trucks, where is the nascar race today, nascar xfinity race, nascar schedule, nascar news, daytona 500, nascar race today, nascar today, nascar race, nascar results, nascar race schedule, nascar live, race scanner, racing scanner, race scanners" /><meta name="rights" content="Copyright - Steven B. Wilson - STS Motorsports Inc. 2005 - 2022" /><meta name="author" content="Speedway Digest Staff" /><meta property="og:url" content="https://speedwaydigest.com/index.php/news/racing-news/73886-2023-calendar-nascar-whelen-euro-series-set-for-historical-season" /><meta property="og:type" content="article" /><meta property="og:title" content="2023 calendar: NASCAR Whelen Euro Series set for historical season" /><meta property="og:description" content="From Finland’s frozen lakes to the woods of Belgium, in 2023 the NASCAR Whelen Euro Series will celebrate NASCAR’s 75th anniversary with a season to remember. The official European NASCAR series will take on six NASCAR GPs, a total of 24 championship races – with Germany returning in the calendar –..." /><meta property="og:image" content="https://www.speedwaydigest.com/media/k2/items/cache/4f5d5bf64e009c58be37af2326c6d978_M.jpg" /><meta name="image" content="https://www.speedwaydigest.com/media/k2/items/cache/4f5d5bf64e009c58be37af2326c6d978_M.jpg" /><meta name="twitter:card" content="summary" /><meta name="twitter:title" content="2023 calendar: NASCAR Whelen Euro Series set for historical season" /><meta name="twitter:description" content="From Finland’s frozen lakes to the woods of Belgium, in 2023 the NASCAR Whelen Euro Series will celebrate NASCAR’s 75th anniversary with a season to remember. The official European NASCAR series will..." /><meta name="twitter:image" content="https://www.speedwaydigest.com/media/k2/items/cache/4f5d5bf64e009c58be37af2326c6d978_M.jpg" /><meta name="twitter:image:alt" content="2023 calendar: NASCAR Whelen Euro Series set for historical season" /><meta name="description" content="From Finland’s frozen lakes to the woods of Belgium, in 2023 the NASCAR Whelen Euro Series will celebrate NASCAR’s 75th anniversary with a season to r..." /><meta name="generator" content="HELIX_ULTIMATE_GENERATOR_TEXT" /><title>2023 calendar: NASCAR Whelen Euro Series set for historical season</title><link href="/index.php/news/racing-news/73886-2023-calendar-nascar-whelen-euro-series-set-for-historical-season" rel="canonical" /><link href="https://speedwaydigest.com/index.php/news/racing-news/73886-2023-calendar-nascar-whelen-euro-series-set-for-historical-season/amp" rel="amphtml" /><link href="/images/favicon.ico" rel="shortcut icon" type="image/vnd.microsoft.icon" /><link href="/favicon.ico" rel="shortcut icon" type="image/vnd.microsoft.icon" /> <script type="application/json" class="joomla-script-options new">{"data":{"breakpoints":{"tablet":991,"mobile":480},"header":{"stickyOffset":"100"}},"csrf.token":"003faec3dbf86b88fe132ccc8290da67","system.paths":{"root":"","base":""}}</script> <script type="application/ld+json">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</script><meta http-equiv="imagetoolbar" content="no"><style id="jch-optimize-critical-css" data-id="a59c074215d3ed53f4a840246b18910ad18e850c757a3faba7a095fdfda82ce2">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</style><link rel="preload" href="/media/com_jchoptimize/cache/css/3a17094011077a1aead096e667287221e92cbf7f0e722da88f6c1cb0b4f2b95a.css" as="style" onload="rel='stylesheet'" /> <script src="/media/com_jchoptimize/cache/js/f4bf04888aba073e62cf7de7bb0c77e4a060daae999a7f6a6ef92eaeb9de6bb6.js"></script> <script async custom-element="amp-ad" src="https://cdn.ampproject.org/v0/amp-ad-0.1.js"></script> <script src="/media/com_jchoptimize/cache/js/f4bf04888aba073e62cf7de7bb0c77e4a8fdc4f154817e2be84bc3ff607a9185.js"></script> <script src="/media/com_jchoptimize/cache/js/f4bf04888aba073e62cf7de7bb0c77e49c87c32bbffdb8c11b47c12910dbf709.js" async></script> </head><body class="site helix-ultimate hu com-k2 view-item layout-default task-none itemid-207 en-gb ltr sticky-header layout-boxed offcanvas-init offcanvs-position-right"><div class="body-wrapper"><div class="body-innerwrapper"><section id="sp-top-bar" class="ts-top-bar-classic d-none d-sm-none d-md-block"><div class="container"><div class="container-inner"><div class="row"><div id="sp-top1" class="col-lg-2 "><div class="sp-column "><div class="sp-module "><div class="sp-module-content"><div id="ts_date155" class="ts_date_area "> <i class="fa fa-calendar-check-o"> </i> Tuesday, Oct 25</div></div></div></div></div><div id="sp-top-menu" class="col-lg-3  d-md-none d-lg-block"><div class="sp-column "></div></div><div id="sp-top3" class="col-lg-7 "><div class="sp-column ts-top-social text-right"><ul class="social-icons"><li class="social-icon-facebook"><a ondragstart="return false;" target="_blank" href="https://www.facebook.com/speedwaydigest" aria-label="facebook"><span class="fa fa-facebook" aria-hidden="true"></span></a></li><li class="social-icon-twitter"><a ondragstart="return false;" target="_blank" href="https://www.twitter.com/speedwaydigest" aria-label="twitter"><span class="fa fa-twitter" aria-hidden="true"></span></a></li><li class="social-icon-pinterest"><a ondragstart="return false;" target="_blank" href="https://www.pinterest.com/speedwaydigest/" aria-label="Pinterest"><span class="fa fa-pinterest" aria-hidden="true"></span></a></li><li><a ondragstart="return false;" target="_blank" href="https://www.youtube.com/channel/UCEHcjt3lx140xojhPUEYZ0A" aria-label="Youtube"><span class="fa fa-youtube" aria-hidden="true"></span></a></li></ul></div></div></div></div></div></section><section id="sp-logo-area"><div class="container"><div class="container-inner"><div class="row"><div id="sp-logo" class="col-md-4 col-lg-3 "><div class="sp-column "><div class="logo"><a ondragstart="return false;" href="/"><img ondragstart="return false;" class="logo-image d-none d-lg-inline-block" src="/images/sdlogoweb.fw.png" alt="Speedway Digest - Home for NASCAR News"><img ondragstart="return false;" class="logo-image-phone d-inline-block d-lg-none" src="/images/sdlogoweb.fw.png" alt="Speedway Digest - Home for NASCAR News"></a></div></div></div><div id="sp-top-banner-2" class="col-md-8 col-lg-9 d-none d-sm-none d-md-block"><div class="sp-column "><div class="sp-module "><div class="sp-module-content"><div class="custom"> <script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-4983971213106691" data-ad-slot="7293211960" data-ad-format="auto"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div></div></div></div></div></div></div></div></section><section id="sp-menu" class="ts-nav-box"><div class="container"><div class="container-inner"><div class="row"><div id="sp-menu" class="col-8 col-md-11 col-lg-11 "><div class="sp-column ts-menu"><nav class="sp-megamenu-wrapper" role="navigation"><a ondragstart="return false;" id="offcanvas-toggler" aria-label="Navigation" class="offcanvas-toggler-right d-block d-lg-none" href="#"><i class="fa fa-bars" aria-hidden="true" title="Navigation"></i></a><ul class="sp-megamenu-parent menu-animation-fade-up d-none d-lg-block"><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php">Home</a></li><li class="sp-menu-item sp-has-child active"><a ondragstart="return false;" href="/index.php/news">News</a><div class="sp-dropdown sp-dropdown-main sp-menu-right" style="width: 200px;"><div class="sp-dropdown-inner"><ul class="sp-dropdown-items"><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/news/nascar-cup-series-news">NASCAR Cup Series News</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/news/xfinity-series-news">Xfinity Series News</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/news/nascar-truck-series-news">NASCAR Truck Series News</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/news/speedway-news">Speedway News</a></li><li class="sp-menu-item current-item active"><a ondragstart="return false;" aria-current="page" href="/index.php/news/racing-news">Racing News</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/news/eracing-news">eRacing News</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/news/latest-news">Latest News</a></li></ul></div></div></li><li class="sp-menu-item sp-has-child"><a ondragstart="return false;" href="/index.php/nascar-schedules">Schedules</a><div class="sp-dropdown sp-dropdown-main sp-menu-right" style="width: 200px;"><div class="sp-dropdown-inner"><ul class="sp-dropdown-items"><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/nascar-schedules/nascar-cup-series-schedule">NASCAR Cup Series Schedule</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/nascar-schedules/xfinity-series-schedule">Xfinity Series Schedule</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/nascar-schedules/nascar-truck-series-schedule">NASCAR Truck Series Schedule</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/nascar-schedules/weekend-schedule">Weekend Schedule</a></li></ul></div></div></li><li class="sp-menu-item sp-has-child"><a ondragstart="return false;" href="/index.php/point-standings">Point Standings</a><div class="sp-dropdown sp-dropdown-main sp-menu-right" style="width: 200px;"><div class="sp-dropdown-inner"><ul class="sp-dropdown-items"><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/point-standings/nascar-cup-series">NASCAR Cup Series</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/point-standings/xfinity-series">Xfinity Series</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/point-standings/nascar-truck-series">NASCAR Truck Series</a></li></ul></div></div></li><li class="sp-menu-item sp-has-child"><a ondragstart="return false;" href="/index.php/scanner-frequencies">Scanner Frequencies</a><div class="sp-dropdown sp-dropdown-main sp-menu-right" style="width: 200px;"><div class="sp-dropdown-inner"><ul class="sp-dropdown-items"><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/scanner-frequencies/nascar-cup-series-frequencies">NASCAR Cup Series Frequencies</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/scanner-frequencies/xfinity-frequencies">Xfinity Frequencies</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/scanner-frequencies/nascar-truck-series-frequencies">NASCAR Truck Series Frequencies</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/scanner-frequencies/arca-series-frequencies">ARCA Series Frequencies </a></li></ul></div></div></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/writers-wanted">Writers Wanted</a></li></ul></nav></div></div><div id="sp-search" class="col-lg-1 "><div class="sp-column "><div class="sp-module  ts-search"><div class="sp-module-content"><div class="nav-search-icon"> <i class="icon icon-search"></i> </div><div class="nav-search-form" style="display: none;"><div class="search ts-search"><form action="/index.php/news/racing-news" method="post"> <input name="searchword" id="mod-search-searchword" maxlength="200" class="inputbox search-query" type="text" size="0" placeholder="Type and hit ENTER" /><span class="search-close">×</span> <input type="hidden" name="task" value="search" /> <input type="hidden" name="option" value="com_search" /> <input type="hidden" name="Itemid" value="207" /> </form></div></div></div></div></div></div></div></div></div></section><section id="sp-main-body"><div class="container"><div class="container-inner"><div class="row"> <main id="sp-component" class="col-lg-8 "><div class="sp-column "><div id="system-message-container"> </div> <span id="startOfPageId73886"></span> <div id="k2Container" class="blog-details-content ts-content-box itemView"><div class="itemHeader"><h2 class="itemTitle"> 2023 calendar: NASCAR Whelen Euro Series set for historical season </h2></div><div class="ItemMetaInfo"> <span class="itemAuthor"> <a ondragstart="return false;" rel="author" href="/index.php/news/racing-news/author/1069-speedwaydigeststaff">Speedway Digest Staff</a> </span> <div class="itemCategory"> <a ondragstart="return false;" href="/index.php/news/racing-news">Racing News</a> </div> <span class="itemDateCreated"> <i class="fa fa-clock-o"></i> Tuesday, Oct 25 </span> <span class="itemHits"> <i class="icon-fire" aria-hidden="true"></i> 38 </span> </div><div class="itemBody"><div class="itemImageBlock"> <span class="itemImage"> <a ondragstart="return false;" data-k2-modal="image" href="/media/k2/items/cache/4f5d5bf64e009c58be37af2326c6d978_XL.jpg" title="Click to preview image"> <img class="jch-lazyload" ondragstart="return false;" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxIiBoZWlnaHQ9IjEiPjwvc3ZnPg==" data-src="/media/k2/items/cache/4f5d5bf64e009c58be37af2326c6d978_L.jpg" alt="2023 calendar: NASCAR Whelen Euro Series set for historical season" style="width:400px; height:auto;" /><noscript><img ondragstart="return false;" src="/media/k2/items/cache/4f5d5bf64e009c58be37af2326c6d978_L.jpg" alt="2023 calendar: NASCAR Whelen Euro Series set for historical season" style="width:400px; height:auto;" /></noscript></a> </span> <div class="clr"></div></div><div class="itemFullText"><p>From Finland’s frozen lakes to the woods of Belgium, in 2023 the NASCAR Whelen Euro Series will celebrate NASCAR’s 75th anniversary with a season to remember. The official European NASCAR series will take on six NASCAR GPs, a total of 24 championship races – with Germany returning in the calendar – and two All-Star non-championship events. <br /> <br /> 2022 marked a year of unprecedented growth for the NASCAR Whelen Euro Series, with all-time record setting numbers across the board: competitors on the grid – 30 or more cars entered all events – spectators at the track and fans watching live and interacting on social media.<br /> <br /> <br /> The 2023 season will be a special one for NASCAR and especially for NASCAR in Europe. Celebrating the 75th anniversary of the most famous organization in Motorsports, a NASCAR Cup Series car will take part in the 24 Hours of Le Mans for the first time in 47 years with the Garage 56 program, adding an unique opportunity to showcase NASCAR to a new audience and put the NASCAR Whelen Euro Series in the spotlight. With the NASCAR GP UK and the Goodwood Festival of Speed following suit, the month of June will be filled with non-stop NASCAR action across the Old Continent.<br /> <br /> “Europe is an important market for NASCAR and the NASCAR Whelen Euro Series will play a key role in NASCAR’s 75th anniversary celebration,” said Chad Seigler, NASCAR Vice President, International. “Next season will give us the opportunity to honor Whelen Euro Series history through milestone races at Valencia and Brands Hatch. We’ll also have our eyes towards the future of NASCAR with the Garage 56 program at the 24 Hours of Le Mans. From traditional races to the unique new NASCAR Arctic Ice Race,  we’re excited for the opportunities the Whelen Euro Series will give us to showcase NASCAR to race fans across Europe.”<br /> <br /> “2023 will be a season to remember for NASCAR in Europe ! A season that makes history, starting with the first ever NASCAR race on ice and passing through amazing events across Europe !”  Explained NWES President CEO Jérome Galpin. “I would like to thank our great Circuit partners from Valencia, Brands Hatch, Vallelunga, Most, Oschersleben, Zolder and Grobnik for all their enthusiasm and continuous efforts to build incredible American events that delight more and more race fans. We are also very excited to be part of the amazing NASCAR Garage 56 program that will for sure draw the eyes of millions of fans in Le Mans, Brands Hatch and Goodwood !”<br /> <br /> An historical 2023 season for the NWES fans and competitors will launch on March 4-5 in Finland, in the breath-taking scenery of frozen lakes, where for the first time in history NASCAR cars will race on ice in  the new NASCAR Arctic Ice Race. Drivers and cars will dance in the snow in a can’t miss all-star event.<br /> <br /> The 2023 NWES championship calendar is a perfect balance between tradition and innovation. The battle to become European NASCAR champion will kick-off in Spain on May 6-7 at Valencia’s Circuit Ricardo Tormo. The traditional venue of EuroNASCAR’s season opener will celebrate the 10th edition of the Valencia NASCAR Fest in style with four races around the 4-Km road course.<br /> <br /> Three weeks of non-stop NASCAR action will take place in June. NASCAR will return to the 24 Hours of Le Mans with the Garage 56 and on June 17-18, one week after the 24 Hours of Le Mans, the protagonists of the NASCAR Whelen Euro Series will return to action in Brands Hatch, UK with one of the crown jewels of the calendar, the hugely popular American SpeedFest, which is celebrating its 10th edition. The busy month of June will continue one week later with the Goodwood Festival of Speed, where the EuroNASCAR cars will return to take part in one of the most prestigious motorsports events in the world together with the NASCAR delegation.<br /> <br /> The Autodromo di Vallelunga will once again host the American Festival of Rome on a classic Italian summer weekend on July 8-9. The Italian venue has rapidly become a staple in the NASCAR Whelen Euro Series calendar and the tifosi will give the event a special atmosphere.<br /> <br /> After the summer break, the action will resume on September 2-3 at Autodrom Most in the Czech Republic with the Autodrom Most NASCAR Show, an event that quickly became one of the most beloved by the fans after its inception in 2019.<br /> <br /> The NASCAR Whelen Euro Series will return to Germany for the first time since 2019 on September 23-24, when Motorsport Arena Oschersleben will host the final rounds of the regular season in the context of a brand new American-themed festival.<br /> <br /> On October 14-15 it will be time to crown champions and trophy winners with a spectacular double-points event. The EuroNASCAR Finals will return to a traditional venue – Belgium’s Circuit Zolder – which for the seventh time in history will host them in the context of the American Festival NASCAR.<br /> <br /> Another non-championship event will take place in 2023: Croatia’s Automotodrom Grobnik will host a special All Star Race on a date and format to be announced.<br /> <br /> The premises are set for another memorable season in the history of NASCAR in Europe. Race fans, start your engines!<br />  </p><table style="border-collapse: collapse;"><colgroup> <col /> <col /> <col width="190" /> <col width="122" /> </colgroup> <tbody> <tr> <td><p dir="ltr" style="color: #000000; font-family: Arial,'Helvetica Neue',Helvetica,sans-serif; font-size: 13px; line-height: 150%; text-align: justify; margin: 10px 0; padding: 0;"><strong>Date</strong></p></td> <td><p dir="ltr" style="color: #000000; font-family: Arial,'Helvetica Neue',Helvetica,sans-serif; font-size: 13px; line-height: 150%; text-align: justify; margin: 10px 0; padding: 0;"><strong>Event</strong></p></td> <td><p dir="ltr" style="color: #000000; font-family: Arial,'Helvetica Neue',Helvetica,sans-serif; font-size: 13px; line-height: 150%; text-align: justify; margin: 10px 0; padding: 0;"><strong>Location</strong></p></td> <td><p dir="ltr" style="color: #000000; font-family: Arial,'Helvetica Neue',Helvetica,sans-serif; font-size: 13px; line-height: 150%; text-align: justify; margin: 10px 0; padding: 0;"><strong>Country</strong></p></td> </tr> <tr> <td><p dir="ltr" style="color: #000000; font-family: Arial,'Helvetica Neue',Helvetica,sans-serif; font-size: 13px; line-height: 150%; text-align: justify; margin: 10px 0; padding: 0;">March 4-5</p></td> <td><p dir="ltr" style="color: #000000; font-family: Arial,'Helvetica Neue',Helvetica,sans-serif; font-size: 13px; line-height: 150%; text-align: justify; margin: 10px 0; padding: 0;">Arctic Ice Race</p></td> <td><p dir="ltr" style="color: #000000; font-family: Arial,'Helvetica Neue',Helvetica,sans-serif; font-size: 13px; line-height: 150%; text-align: justify; margin: 10px 0; padding: 0;">Rovaniemi</p></td> <td><p dir="ltr" style="color: #000000; font-family: Arial,'Helvetica Neue',Helvetica,sans-serif; font-size: 13px; line-height: 150%; text-align: justify; margin: 10px 0; padding: 0;">Finland</p></td> </tr> <tr> <td><p dir="ltr" style="color: #000000; font-family: Arial,'Helvetica Neue',Helvetica,sans-serif; font-size: 13px; line-height: 150%; text-align: justify; margin: 10px 0; padding: 0;">May 6-7</p></td> <td><p dir="ltr" style="color: #000000; font-family: Arial,'Helvetica Neue',Helvetica,sans-serif; font-size: 13px; line-height: 150%; text-align: justify; margin: 10px 0; padding: 0;">NASCAR GP Spain        </p></td> <td><p dir="ltr" style="color: #000000; font-family: Arial,'Helvetica Neue',Helvetica,sans-serif; font-size: 13px; line-height: 150%; text-align: justify; margin: 10px 0; padding: 0;">Circuit Ricardo Tormo</p></td> <td><p dir="ltr" style="color: #000000; font-family: Arial,'Helvetica Neue',Helvetica,sans-serif; font-size: 13px; line-height: 150%; text-align: justify; margin: 10px 0; padding: 0;">Spain</p></td> </tr> <tr> <td><p dir="ltr" style="color: #000000; font-family: Arial,'Helvetica Neue',Helvetica,sans-serif; font-size: 13px; line-height: 150%; text-align: justify; margin: 10px 0; padding: 0;">June 17-18</p></td> <td><p dir="ltr" style="color: #000000; font-family: Arial,'Helvetica Neue',Helvetica,sans-serif; font-size: 13px; line-height: 150%; text-align: justify; margin: 10px 0; padding: 0;">NASCAR GP UK</p></td> <td><p dir="ltr" style="color: #000000; font-family: Arial,'Helvetica Neue',Helvetica,sans-serif; font-size: 13px; line-height: 150%; text-align: justify; margin: 10px 0; padding: 0;">Brands Hatch Indy Circuit</p></td> <td><p dir="ltr" style="color: #000000; font-family: Arial,'Helvetica Neue',Helvetica,sans-serif; font-size: 13px; line-height: 150%; text-align: justify; margin: 10px 0; padding: 0;">UK</p></td> </tr> <tr> <td><p dir="ltr" style="color: #000000; font-family: Arial,'Helvetica Neue',Helvetica,sans-serif; font-size: 13px; line-height: 150%; text-align: justify; margin: 10px 0; padding: 0;">July 8-9</p></td> <td><p dir="ltr" style="color: #000000; font-family: Arial,'Helvetica Neue',Helvetica,sans-serif; font-size: 13px; line-height: 150%; text-align: justify; margin: 10px 0; padding: 0;">NASCAR GP Italy</p></td> <td><p dir="ltr" style="color: #000000; font-family: Arial,'Helvetica Neue',Helvetica,sans-serif; font-size: 13px; line-height: 150%; text-align: justify; margin: 10px 0; padding: 0;">Autodromo di Vallelunga</p></td> <td><p dir="ltr" style="color: #000000; font-family: Arial,'Helvetica Neue',Helvetica,sans-serif; font-size: 13px; line-height: 150%; text-align: justify; margin: 10px 0; padding: 0;">Italy</p></td> </tr> <tr> <td><p dir="ltr" style="color: #000000; font-family: Arial,'Helvetica Neue',Helvetica,sans-serif; font-size: 13px; line-height: 150%; text-align: justify; margin: 10px 0; padding: 0;">September 2-3</p></td> <td><p dir="ltr" style="color: #000000; font-family: Arial,'Helvetica Neue',Helvetica,sans-serif; font-size: 13px; line-height: 150%; text-align: justify; margin: 10px 0; padding: 0;">NASCAR GP Czechia</p></td> <td><p dir="ltr" style="color: #000000; font-family: Arial,'Helvetica Neue',Helvetica,sans-serif; font-size: 13px; line-height: 150%; text-align: justify; margin: 10px 0; padding: 0;">Autodrom Most</p></td> <td><p dir="ltr" style="color: #000000; font-family: Arial,'Helvetica Neue',Helvetica,sans-serif; font-size: 13px; line-height: 150%; text-align: justify; margin: 10px 0; padding: 0;">Czech Republic</p></td> </tr> <tr> <td><p dir="ltr" style="color: #000000; font-family: Arial,'Helvetica Neue',Helvetica,sans-serif; font-size: 13px; line-height: 150%; text-align: justify; margin: 10px 0; padding: 0;">September 23-24</p></td> <td><p dir="ltr" style="color: #000000; font-family: Arial,'Helvetica Neue',Helvetica,sans-serif; font-size: 13px; line-height: 150%; text-align: justify; margin: 10px 0; padding: 0;">NASCAR GP Germany   </p></td> <td><p dir="ltr" style="color: #000000; font-family: Arial,'Helvetica Neue',Helvetica,sans-serif; font-size: 13px; line-height: 150%; text-align: justify; margin: 10px 0; padding: 0;">Oschersleben</p></td> <td><p dir="ltr" style="color: #000000; font-family: Arial,'Helvetica Neue',Helvetica,sans-serif; font-size: 13px; line-height: 150%; text-align: justify; margin: 10px 0; padding: 0;">Germany</p></td> </tr> <tr> <td><p dir="ltr" style="color: #000000; font-family: Arial,'Helvetica Neue',Helvetica,sans-serif; font-size: 13px; line-height: 150%; text-align: justify; margin: 10px 0; padding: 0;">October 14-15</p></td> <td><p dir="ltr" style="color: #000000; font-family: Arial,'Helvetica Neue',Helvetica,sans-serif; font-size: 13px; line-height: 150%; text-align: justify; margin: 10px 0; padding: 0;">NASCAR GP Belgium</p></td> <td><p dir="ltr" style="color: #000000; font-family: Arial,'Helvetica Neue',Helvetica,sans-serif; font-size: 13px; line-height: 150%; text-align: justify; margin: 10px 0; padding: 0;">Circuit Zolder</p></td> <td><p dir="ltr" style="color: #000000; font-family: Arial,'Helvetica Neue',Helvetica,sans-serif; font-size: 13px; line-height: 150%; text-align: justify; margin: 10px 0; padding: 0;">Belgium</p></td> </tr> <tr> <td><p dir="ltr" style="color: #000000; font-family: Arial,'Helvetica Neue',Helvetica,sans-serif; font-size: 13px; line-height: 150%; text-align: justify; margin: 10px 0; padding: 0;">TBD</p></td> <td><p dir="ltr" style="color: #000000; font-family: Arial,'Helvetica Neue',Helvetica,sans-serif; font-size: 13px; line-height: 150%; text-align: justify; margin: 10px 0; padding: 0;">All Star Race</p></td> <td><p dir="ltr" style="color: #000000; font-family: Arial,'Helvetica Neue',Helvetica,sans-serif; font-size: 13px; line-height: 150%; text-align: justify; margin: 10px 0; padding: 0;">Automotodrom Grobnik</p></td> <td><p dir="ltr" style="color: #000000; font-family: Arial,'Helvetica Neue',Helvetica,sans-serif; font-size: 13px; line-height: 150%; text-align: justify; margin: 10px 0; padding: 0;">Croatia</p></td> </tr> </tbody> </table><p>NWES PR</p></div><div class="clr"></div><div class="itemToolbarContent"><div class="itemRatingBlock"> <span>Rate this item</span> <div class="itemRatingForm"><ul class="itemRatingList"> <li class="itemCurrentRating" id="itemCurrentRating73886" style="width:0%;"></li> <li><a ondragstart="return false;" href="#" data-id="73886" title="1 star out of 5" class="one-star">1</a></li> <li><a ondragstart="return false;" href="#" data-id="73886" title="2 stars out of 5" class="two-stars">2</a></li> <li><a ondragstart="return false;" href="#" data-id="73886" title="3 stars out of 5" class="three-stars">3</a></li> <li><a ondragstart="return false;" href="#" data-id="73886" title="4 stars out of 5" class="four-stars">4</a></li> <li><a ondragstart="return false;" href="#" data-id="73886" title="5 stars out of 5" class="five-stars">5</a></li> </ul><div id="itemRatingLog73886" class="itemRatingLog">(0 votes)</div><div class="clr"></div></div><div class="clr"></div></div><div class="itemToolbar float-right"><ul> <li> <span class="itemTextResizerTitle">font size</span> <a ondragstart="return false;" href="#" id="fontDecrease"> <span>decrease font size</span> </a> <a ondragstart="return false;" href="#" id="fontIncrease"> <span>increase font size</span> </a> </li> <li> <a ondragstart="return false;" class="itemPrintLink" rel="nofollow" href="/index.php/news/racing-news/73886-2023-calendar-nascar-whelen-euro-series-set-for-historical-season?tmpl=component&amp;print=1" onclick="window.open(this.href,'printWindow','width=900,height=600,location=no,menubar=no,resizable=yes,scrollbars=yes'); return false;"> <span>Print</span> </a> </li> <li> <a ondragstart="return false;" class="itemEmailLink" rel="nofollow" href="/index.php/component/mailto/?tmpl=component&amp;template=ts_newslinen&amp;link=27ac08cf7d4e2e31c0ca1526617e9e74f89d77f5" onclick="window.open(this.href,'emailWindow','width=400,height=350,location=no,menubar=no,resizable=no,scrollbars=no'); return false;"> <span>Email</span> </a> </li> </ul><div class="clr"></div></div></div><div class="itemContentFooter"><div class="clr"></div></div><div class="clr"></div></div><div class="itemSocialSharing"><div class="itemTwitterButton"> <a ondragstart="return false;" href="https://twitter.com/share" class="twitter-share-button" data-lang="en-gb" data-via="">Tweet</a> <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document,'script','twitter-wjs');</script> </div><div class="itemFacebookButton"><div id="fb-root"></div> <script>(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(d.getElementById(id))return;js=d.createElement(s);js.id=id;js.src="//connect.facebook.net/en_GB/sdk.js#xfbml=1&version=v2.5";fjs.parentNode.insertBefore(js,fjs);}(document,'script','facebook-jssdk'));</script><div class="fb-like" data-width="200" data-layout="button_count" data-action="like" data-show-faces="false" data-share="false"></div></div><div class="clr"></div></div><div class="itemLinks"><div class="clr"></div></div><div class="itemNavigation"> <a ondragstart="return false;" class="itemPrevious" href="/index.php/news/racing-news/73883-7th-heaven-kody-swanson-is-usac-s-silver-crown-champ-doran-dyson-the-entrant-kings">&laquo; 7th Heaven: Kody Swanson is USAC’s Silver Crown Champ, Doran-Dyson the Entrant Kings</a> <a ondragstart="return false;" class="itemNext" href="/index.php/news/racing-news/73889-david-mccoy-joins-coltman-farms-racing">David McCoy joins Coltman Farms Racing &raquo;</a> </div><div class="itemAuthorBlock"> <img ondragstart="return false;" class="itemAuthorAvatar jch-lazyload" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxIiBoZWlnaHQ9IjEiPjwvc3ZnPg==" data-src="/media/k2/users/13.png" alt="Speedway Digest Staff" /><noscript><img ondragstart="return false;" class="itemAuthorAvatar" src="/media/k2/users/13.png" alt="Speedway Digest Staff" /></noscript><div class="itemAuthorDetails"><h3 class="itemAuthorName"> <a ondragstart="return false;" rel="author" href="/index.php/news/racing-news/author/1069-speedwaydigeststaff">Speedway Digest Staff</a> </h3><p><p>Follow us on Twitter <a ondragstart="return false;" href="https://www.twitter.com/speedwaydigest">@SpeedwayDigest</a></p></p><div class="clr"></div><div class="clr"></div></div><div class="clr"></div></div><div class="itemAuthorLatest"><h3>Latest from Speedway Digest Staff</h3><ul> <li class="even"> <a ondragstart="return false;" href="/index.php/news/nascar-truck-series-news/73907-daniel-dye-signed-to-compete-full-time-in-the-nascar-craftsman-truck-series-for-gms-racing-in-2023">Daniel Dye Signed to Compete Full-Time in the NASCAR Craftsman Truck Series for GMS Racing in 2023</a> </li> <li class="odd"> <a ondragstart="return false;" href="/index.php/news/nascar-cup-series-news/73906-kaulig-racing-weekly-advance-martinsville-speedway">Kaulig Racing Weekly Advance | Martinsville Speedway</a> </li> <li class="even"> <a ondragstart="return false;" href="/index.php/news/racing-news/73905-nascar-and-floracing-deepen-commitment-to-grassroots-racing-increase-race-purse-by-30-000-for-south-carolina-400-at-florence-motor-speedway-on-nov-18-19">NASCAR and FloRacing deepen commitment to grassroots racing, increase race purse by $30,000 for South Carolina 400 at Florence Motor Speedway on Nov. 18-19</a> </li> <li class="odd"> <a ondragstart="return false;" href="/index.php/news/nascar-cup-series-news/73904-moji-sushi-partners-with-front-row-motorsports">Moji Sushi Partners with Front Row Motorsports</a> </li> <li class="even"> <a ondragstart="return false;" href="/index.php/news/racing-news/73903-lucas-oil-american-sprint-car-series-headlining-fuzzy-s-fall-fling-at-creek-county-speedway">Lucas Oil American Sprint Car Series Headlining Fuzzy’s Fall Fling At Creek County Speedway!</a> </li> </ul><div class="clr"></div></div><div class="clr"></div><div class="itemBackToTop"> <a ondragstart="return false;" class="k2Anchor" href="/index.php/news/racing-news/73886-2023-calendar-nascar-whelen-euro-series-set-for-historical-season#startOfPageId73886"> back to top </a> </div><div class="clr"></div></div></div></main><aside id="sp-right" class="col-lg-4 "><div class="sp-column "><div class="sp-module "><div class="sp-module-content"><div class="custom"> <center><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-4983971213106691" data-ad-slot="1381625561" data-ad-format="auto" data-full-width-responsive="true"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></center></div></div></div><div class="sp-module "><div class="sp-module-content"><div class="custom"> <center><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-4983971213106691" data-ad-slot="1381625561" data-ad-format="auto" data-full-width-responsive="true"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></center></div></div></div></div></aside></div></div></div></section><footer id="sp-footer" class="ts-footer"><div class="row"><div id="sp-footer1" class="col-lg-6 "><div class="sp-column text-center"><span class="sp-copyright">Copyright © 2010 - 2022 STS Motorsports Inc. All Rights Reserved.</span></div></div><div id="sp-footer2" class="col-lg-6 "><div class="sp-column "><div class="sp-module "><div class="sp-module-content"><ul class="menu nav-pills"> <li class="item-1557"><a ondragstart="return false;" href="/index.php/advertise">Advertise</a></li><li class="item-1559"><a ondragstart="return false;" href="/index.php/privacy-policy">Privacy Policy</a></li><li class="item-1621"><a ondragstart="return false;" href="/index.php/sitemap">Sitemap</a></li><li class="item-1558"><a ondragstart="return false;" href="/index.php/sd-staff">SD Staff</a></li><li class="item-1576"><a ondragstart="return false;" href="/index.php/writer-login">Writer Login</a></li></ul></div></div></div></div></div></footer></div></div><div class="offcanvas-overlay"></div><div class="offcanvas-menu"> <a ondragstart="return false;" href="#" class="close-offcanvas"><span class="fa fa-remove"></span></a> <div class="offcanvas-inner"><div class="sp-module "><div class="sp-module-content"><ul class="menu"> <li class="item-241 default"><a ondragstart="return false;" href="/index.php">Home</a></li><li class="item-186 active menu-deeper menu-parent"><a ondragstart="return false;" href="/index.php/news">News<span class="menu-toggler"></span></a><ul class="menu-child"><li class="item-205"><a ondragstart="return false;" href="/index.php/news/nascar-cup-series-news">NASCAR Cup Series News</a></li><li class="item-188"><a ondragstart="return false;" href="/index.php/news/xfinity-series-news">Xfinity Series News</a></li><li class="item-1922"><a ondragstart="return false;" href="/index.php/news/nascar-truck-series-news">NASCAR Truck Series News</a></li><li class="item-190"><a ondragstart="return false;" href="/index.php/news/speedway-news">Speedway News</a></li><li class="item-207 current active"><a ondragstart="return false;" href="/index.php/news/racing-news">Racing News</a></li><li class="item-2153"><a ondragstart="return false;" href="/index.php/news/eracing-news">eRacing News</a></li><li class="item-1876"><a ondragstart="return false;" href="/index.php/news/latest-news">Latest News</a></li></ul></li><li class="item-197 menu-deeper menu-parent"><a ondragstart="return false;" href="/index.php/nascar-schedules">Schedules<span class="menu-toggler"></span></a><ul class="menu-child"><li class="item-198"><a ondragstart="return false;" href="/index.php/nascar-schedules/nascar-cup-series-schedule">NASCAR Cup Series Schedule</a></li><li class="item-199"><a ondragstart="return false;" href="/index.php/nascar-schedules/xfinity-series-schedule">Xfinity Series Schedule</a></li><li class="item-200"><a ondragstart="return false;" href="/index.php/nascar-schedules/nascar-truck-series-schedule">NASCAR Truck Series Schedule</a></li><li class="item-202"><a ondragstart="return false;" href="/index.php/nascar-schedules/weekend-schedule">Weekend Schedule</a></li></ul></li><li class="item-208 menu-deeper menu-parent"><a ondragstart="return false;" href="/index.php/point-standings">Point Standings<span class="menu-toggler"></span></a><ul class="menu-child"><li class="item-209"><a ondragstart="return false;" href="/index.php/point-standings/nascar-cup-series">NASCAR Cup Series</a></li><li class="item-210"><a ondragstart="return false;" href="/index.php/point-standings/xfinity-series">Xfinity Series</a></li><li class="item-211"><a ondragstart="return false;" href="/index.php/point-standings/nascar-truck-series">NASCAR Truck Series</a></li></ul></li><li class="item-204 menu-deeper menu-parent"><a ondragstart="return false;" href="/index.php/scanner-frequencies">Scanner Frequencies<span class="menu-toggler"></span></a><ul class="menu-child"><li class="item-235"><a ondragstart="return false;" href="/index.php/scanner-frequencies/nascar-cup-series-frequencies">NASCAR Cup Series Frequencies</a></li><li class="item-236"><a ondragstart="return false;" href="/index.php/scanner-frequencies/xfinity-frequencies">Xfinity Frequencies</a></li><li class="item-237"><a ondragstart="return false;" href="/index.php/scanner-frequencies/nascar-truck-series-frequencies">NASCAR Truck Series Frequencies</a></li><li class="item-1596"><a ondragstart="return false;" href="/index.php/scanner-frequencies/arca-series-frequencies">ARCA Series Frequencies </a></li></ul></li><li class="item-606"><a ondragstart="return false;" href="/index.php/writers-wanted">Writers Wanted</a></li></ul></div></div></div></div> <a ondragstart="return false;" href="#" class="sp-scroll-up" aria-label="Scroll Up"><span class="fa fa-chevron-up" aria-hidden="true"></span></a> <amp-ad width="100vw" height="320" type="adsense" data-ad-client="ca-pub-4983971213106691" data-ad-slot="1381625561" data-auto-format="rspv" data-full-width=""><div overflow=""></div></amp-ad><div id="openModal" class="modalDialog"><div> <a ondragstart="return false;" href="#close" title="Close" id="close" class="close">X</a> <h2>No right click</h2><p>Please link the article. </p></div></div> <script type="text/javascript">disableSelection(document.body)</script> </body> </html>