<!doctype html><html prefix="og: http://ogp.me/ns#" lang="en-gb" dir="ltr"><head><meta charset="utf-8"><meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no"><link rel="canonical" href="https://speedwaydigest.com/index.php/news/racing-news/66263-imsa-weathertech-championship-on-nbc-sports-produces-significant-viewership-gains-for-third-consecutive-year"><base href="https://speedwaydigest.com/index.php/news/racing-news/66263-imsa-weathertech-championship-on-nbc-sports-produces-significant-viewership-gains-for-third-consecutive-year" /><meta http-equiv="content-type" content="text/html; charset=utf-8" /><meta name="keywords" content="NASCAR, NASCAR News, NASCAR Drivers, NASCAR Frequencies, NASCAR Cup Series, Monster Cup, XFINITY, Xfinity Series, Camping World, Camping World Truck Series, NASCAR Points, Speedway Digest, Speedway Digest NASCAR News, Daytona, Richmond, Martinsville, Dover, Charlotte, Darlington, North Wilkesboro, Texas Motor Speedway, Pocono Speedway, Watkins Glen, Auto Club Speedway, Bristol Motor Speedway, Kansas Speedway, Talladega Superspeedway, Atlanta Motor Speedway, News, Jimmie Johnson, Roush Racing, Hendricks Motorsports, BK Racing, Wood Brothers Racing, Richard Petty Motorsports, Yates Racing, Robert Yates Racing, Michael Waltrip Racing, Carl Edwards, Trevor Bayne, Save The Speedway, North Wilkesboro Speedway, Dale Earnhardt, Dale Earnhardt Jr., NASCAR Frequencies, Monster Energy NASCAR Cup Series, Monster Energy Series, XFINITY Series, Camping World Truck Series, Las Vegas Motor Speedway, Phoenix International Raceway, Charlotte Motor Speedway, New Hampshire Motor Speedway, Gateway Motorsports Park, Darlington Raceway, Ryan Blaney, Chase Elliott, Ford Performance, Team Chevy, Toyota Racing, Kyle Busch, Kurt Busch, Denny Hamlin, NASCAR schedule, nascar race today, nascar race schedule, nascar race results, nascar race this weekend, nascar race results today, nascar truck race, nascar trucks, where is the nascar race today, nascar xfinity race, nascar schedule, nascar news, daytona 500, nascar race today, nascar today, nascar race, nascar results, nascar race schedule, nascar live, race scanner, racing scanner, race scanners" /><meta name="rights" content="Copyright - Steven B. Wilson - STS Motorsports Inc. 2005 - 2021" /><meta name="author" content="Speedway Digest Staff" /><meta property="og:url" content="https://speedwaydigest.com/index.php/news/racing-news/66263-imsa-weathertech-championship-on-nbc-sports-produces-significant-viewership-gains-for-third-consecutive-year" /><meta property="og:type" content="article" /><meta property="og:title" content="Imsa Weathertech Championship on NBC Sports Produces Significant Viewership Gains for Third Consecutive Year" /><meta property="og:description" content="NBC Sports delivered significant viewership gains and milestones for the third consecutive year for the IMSA WeatherTech SportsCar Championship in 2021, doubling the series’ viewership in three years and delivering the most-watched IMSA race in 13 years. NBC Sports’ 2021 IMSA WeatherTech Championshi..." /><meta property="og:image" content="https://www.speedwaydigest.com/media/k2/items/cache/47dd2f837f21a1d7cda5002eff2e3baa_M.jpg" /><meta name="image" content="https://www.speedwaydigest.com/media/k2/items/cache/47dd2f837f21a1d7cda5002eff2e3baa_M.jpg" /><meta name="twitter:card" content="summary" /><meta name="twitter:title" content="Imsa Weathertech Championship on NBC Sports Produces Significant Viewership Gains for Third Consecutive Year" /><meta name="twitter:description" content="NBC Sports delivered significant viewership gains and milestones for the third consecutive year for the IMSA WeatherTech SportsCar Championship in 2021, doubling the series’ viewership in three years..." /><meta name="twitter:image" content="https://www.speedwaydigest.com/media/k2/items/cache/47dd2f837f21a1d7cda5002eff2e3baa_M.jpg" /><meta name="twitter:image:alt" content="Imsa Weathertech Championship on NBC Sports Produces Significant Viewership Gains for Third Consecutive Year" /><meta name="description" content="NBC Sports delivered significant viewership gains and milestones for the third consecutive year for the IMSA WeatherTech SportsCar Championship in 202..." /><title>Imsa Weathertech Championship on NBC Sports Produces Significant Viewership Gains for Third Consecutive Year</title><link href="/index.php/news/racing-news/66263-imsa-weathertech-championship-on-nbc-sports-produces-significant-viewership-gains-for-third-consecutive-year" rel="canonical" /><link href="https://speedwaydigest.com/index.php/news/racing-news/66263-imsa-weathertech-championship-on-nbc-sports-produces-significant-viewership-gains-for-third-consecutive-year/amp" rel="amphtml" /><link href="/images/favicon.ico" rel="shortcut icon" type="image/vnd.microsoft.icon" /><link href="/favicon.ico" rel="shortcut icon" type="image/vnd.microsoft.icon" /> <script type="application/json" class="joomla-script-options new">{"data":{"breakpoints":{"tablet":991,"mobile":480},"header":{"stickyOffset":"100"}},"csrf.token":"8bb8edb03b5c423c00da6c46730127dd","system.paths":{"root":"","base":""}}</script> <script type="application/ld+json">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</script><meta http-equiv="imagetoolbar" content="no"><link rel="preload" as="style" href="/media/com_jchoptimize/cache/css/0c0438ad1a0c727347dda196b624231f.css" onload="this.rel='stylesheet'" /><style id="jch-optimize-critical-css">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</style> <script src="/media/com_jchoptimize/cache/js/0888b3fa52bf72175f0dba5104ede10a.js"></script> <script async custom-element="amp-ad" src="https://cdn.ampproject.org/v0/amp-ad-0.1.js"></script> <script src="/media/com_jchoptimize/cache/js/f24e016c312a3c66190c9bc1399b4f99.js"></script><noscript><style type="text/css">img.jch-lazyload,iframe.jch-lazyload{display:none}</style> </noscript> </head><body class="site helix-ultimate hu com-k2 view-item layout-default task-none itemid-207 en-gb ltr sticky-header layout-boxed offcanvas-init offcanvs-position-right"><div class="body-wrapper"><div class="body-innerwrapper"><section id="sp-top-bar" class="ts-top-bar-classic d-none d-sm-none d-md-block"><div class="container"><div class="container-inner"><div class="row"><div id="sp-top1" class="col-lg-2 "><div class="sp-column "><div class="sp-module "><div class="sp-module-content"><div id="ts_date155" class="ts_date_area "> <i class="fa fa-calendar-check-o"> </i> Thursday, Dec 02</div></div></div></div></div><div id="sp-top-menu" class="col-lg-3  d-md-none d-lg-block"><div class="sp-column "></div></div><div id="sp-top3" class="col-lg-7 "><div class="sp-column ts-top-social text-right"><ul class="social-icons"><li class="social-icon-facebook"><a ondragstart="return false;" target="_blank" href="https://www.facebook.com/speedwaydigest" aria-label="facebook"><span class="fa fa-facebook" aria-hidden="true"></span></a></li><li class="social-icon-twitter"><a ondragstart="return false;" target="_blank" href="https://www.twitter.com/speedwaydigest" aria-label="twitter"><span class="fa fa-twitter" aria-hidden="true"></span></a></li><li class="social-icon-pinterest"><a ondragstart="return false;" target="_blank" href="https://www.pinterest.com/speedwaydigest/" aria-label="Pinterest"><span class="fa fa-pinterest" aria-hidden="true"></span></a></li><li><a ondragstart="return false;" target="_blank" href="https://www.youtube.com/channel/UCEHcjt3lx140xojhPUEYZ0A" aria-label="Youtube"><span class="fa fa-youtube" aria-hidden="true"></span></a></li></ul></div></div></div></div></div></section><section id="sp-logo-area"><div class="container"><div class="container-inner"><div class="row"><div id="sp-logo" class="col-md-4 col-lg-3 "><div class="sp-column "><div class="logo"><a ondragstart="return false;" href="/"><img ondragstart="return false;" class="logo-image d-none d-lg-inline-block" src="/images/sdlogoweb.fw.png" alt="Speedway Digest - Home for NASCAR News"><img ondragstart="return false;" class="logo-image-phone d-inline-block d-lg-none" src="/images/sdlogoweb.fw.png" alt="Speedway Digest - Home for NASCAR News"></a></div></div></div><div id="sp-top-banner-2" class="col-md-8 col-lg-9 d-none d-sm-none d-md-block"><div class="sp-column "><div class="sp-module "><div class="sp-module-content"><div class="custom"> <script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-4983971213106691" data-ad-slot="7293211960" data-ad-format="auto"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div></div></div></div></div></div></div></div></section><section id="sp-menu" class="ts-nav-box"><div class="container"><div class="container-inner"><div class="row"><div id="sp-menu" class="col-8 col-md-11 col-lg-12 "><div class="sp-column ts-menu"><nav class="sp-megamenu-wrapper" role="navigation"><a ondragstart="return false;" id="offcanvas-toggler" aria-label="Navigation" class="offcanvas-toggler-right d-block d-lg-none" href="#"><i class="fa fa-bars" aria-hidden="true" title="Navigation"></i></a><ul class="sp-megamenu-parent menu-animation-fade-up d-none d-lg-block"><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php">Home</a></li><li class="sp-menu-item sp-has-child active"><a ondragstart="return false;" href="/index.php/news">News</a><div class="sp-dropdown sp-dropdown-main sp-menu-right" style="width: 200px;"><div class="sp-dropdown-inner"><ul class="sp-dropdown-items"><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/news/nascar-cup-series-news">NASCAR Cup Series News</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/news/xfinity-series-news">Xfinity Series News</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/news/nascar-truck-series-news">NASCAR Truck Series News</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/news/speedway-news">Speedway News</a></li><li class="sp-menu-item current-item active"><a ondragstart="return false;" aria-current="page" href="/index.php/news/racing-news">Racing News</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/news/eracing-news">eRacing News</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/news/latest-news">Latest News</a></li></ul></div></div></li><li class="sp-menu-item sp-has-child"><a ondragstart="return false;" href="/index.php/nascar-schedules">Schedules</a><div class="sp-dropdown sp-dropdown-main sp-menu-right" style="width: 200px;"><div class="sp-dropdown-inner"><ul class="sp-dropdown-items"><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/nascar-schedules/nascar-cup-series-schedule">NASCAR Cup Series Schedule</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/nascar-schedules/xfinity-series-schedule">Xfinity Series Schedule</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/nascar-schedules/nascar-truck-series-schedule">NASCAR Truck Series Schedule</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/nascar-schedules/weekend-schedule">Weekend Schedule</a></li></ul></div></div></li><li class="sp-menu-item sp-has-child"><a ondragstart="return false;" href="/index.php/point-standings">Point Standings</a><div class="sp-dropdown sp-dropdown-main sp-menu-right" style="width: 200px;"><div class="sp-dropdown-inner"><ul class="sp-dropdown-items"><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/point-standings/nascar-cup-series">NASCAR Cup Series</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/point-standings/xfinity-series">Xfinity Series</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/point-standings/nascar-truck-series">NASCAR Truck Series</a></li></ul></div></div></li><li class="sp-menu-item sp-has-child"><a ondragstart="return false;" href="/index.php/scanner-frequencies">Scanner Frequencies</a><div class="sp-dropdown sp-dropdown-main sp-menu-right" style="width: 200px;"><div class="sp-dropdown-inner"><ul class="sp-dropdown-items"><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/scanner-frequencies/nascar-cup-series-frequencies">NASCAR Cup Series Frequencies</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/scanner-frequencies/xfinity-frequencies">Xfinity Frequencies</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/scanner-frequencies/nascar-truck-series-frequencies">NASCAR Truck Series Frequencies</a></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/scanner-frequencies/arca-series-frequencies">ARCA Series Frequencies </a></li></ul></div></div></li><li class="sp-menu-item"><a ondragstart="return false;" href="/index.php/writers-wanted">Writers Wanted</a></li></ul></nav></div></div></div></div></div></section><section id="sp-main-body"><div class="container"><div class="container-inner"><div class="row"> <main id="sp-component" class="col-lg-8 "><div class="sp-column "><div id="system-message-container"> </div> <span id="startOfPageId66263"></span> <div id="k2Container" class="blog-details-content ts-content-box itemView"><div class="itemHeader"><h2 class="itemTitle"> Imsa Weathertech Championship on NBC Sports Produces Significant Viewership Gains for Third Consecutive Year </h2></div><div class="ItemMetaInfo"> <span class="itemAuthor"> <a ondragstart="return false;" rel="author" href="/index.php/news/racing-news/author/1069-speedwaydigeststaff">Speedway Digest Staff</a> </span> <div class="itemCategory"> <a ondragstart="return false;" href="/index.php/news/racing-news">Racing News</a> </div> <span class="itemDateCreated"> <i class="fa fa-clock-o"></i> Thursday, Dec 02 </span> <span class="itemHits"> <i class="icon-fire" aria-hidden="true"></i> 12 </span> </div><div class="itemBody"><div class="itemImageBlock"> <span class="itemImage"> <a ondragstart="return false;" data-k2-modal="image" href="/media/k2/items/cache/47dd2f837f21a1d7cda5002eff2e3baa_XL.jpg" title="Click to preview image"> <img class="jch-lazyload" ondragstart="return false;" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxIiBoZWlnaHQ9IjEiPjwvc3ZnPg==" data-src="/media/k2/items/cache/47dd2f837f21a1d7cda5002eff2e3baa_L.jpg" alt="Imsa Weathertech Championship on NBC Sports Produces Significant Viewership Gains for Third Consecutive Year" style="width:400px; height:auto;" /><noscript><img ondragstart="return false;" src="/media/k2/items/cache/47dd2f837f21a1d7cda5002eff2e3baa_L.jpg" alt="Imsa Weathertech Championship on NBC Sports Produces Significant Viewership Gains for Third Consecutive Year" style="width:400px; height:auto;" /></noscript></a> </span> <div class="clr"></div></div><div class="itemFullText"><p style="text-align: justify; margin-bottom: 11px;"><span style="font-size: 11pt;"><span style="font-family: arial,helvetica,sans-serif;"><span style="font-size: 12pt;"><span style="font-family: times new roman,times;">NBC Sports delivered significant viewership gains and milestones for the third consecutive year for the IMSA WeatherTech SportsCar Championship in 2021, <u>doubling the series’ viewership in three years and delivering the most-watched IMSA race in 13 years</u>.</span></span></span></span></p><p style="text-align: justify; margin-bottom: 11px;"><span style="font-size: 12pt;"><span style="font-family: times new roman,times;">NBC Sports’ 2021 IMSA WeatherTech Championship coverage across NBC and NBCSN averaged 254,000 viewers, according to Nielsen. NBC Sports has doubled the viewership for the IMSA WeatherTech Championship in three years since acquiring the rights in 2018 (128,000 viewers on FOX/FS1/FS2).</span></span></p><p style="text-align: justify; margin-bottom: 11px;"><span style="font-size: 12pt;"><span style="font-family: times new roman,times;">Season-long IMSA viewership highlights were led by NBC Sports’ coverage of the Rolex 24 At Daytona on Jan. 31, which averaged 1.23 million viewers on NBC – up 24% vs. 2020 – to rank as the most-watched IMSA race since 2008 (Rolex 24 At Daytona; 1.27 million). </span></span></p><p style="text-align: justify; margin-bottom: 11px;"><span style="font-size: 12pt;"><span style="font-family: times new roman,times;">Additional 2021 NBC Sports IMSA viewership highlights:</span></span></p><ul> <li style="font-family: arial,helvetica,sans-serif; font-size: 12pt; margin-left: 8px;"><span style="font-size: 11pt;"><span style="font-family: arial,helvetica,sans-serif;"><span style="font-size: 12pt;"><span style="font-family: times new roman,times;">Complete Rolex 24 At Daytona coverage on NBC (Jan. 30-31) averaged nearly 1.1 million viewers (1.096 million), up 30% vs. the two comparable telecasts on NBC last year (846,000);</span></span></span></span></li> </ul><ul> <li style="font-family: arial,helvetica,sans-serif; font-size: 12pt; margin-left: 8px; text-align: justify;"><span style="font-size: 11pt;"><span style="font-family: arial,helvetica,sans-serif;"><span style="font-size: 12pt;"><span style="font-family: times new roman,times;">Season-long viewership on NBC (four telecasts) averaged 679,000 viewers, up 6% vs. 2020 and up 52% vs. 2019;</span></span></span></span></li> </ul><ul> <li style="font-family: arial,helvetica,sans-serif; font-size: 12pt; margin-left: 8px; text-align: justify;"><span style="font-size: 11pt;"><span style="font-family: arial,helvetica,sans-serif;"><span style="font-size: 12pt;"><span style="font-family: times new roman,times;">The Rolex 24 delivered NBCSN’s most-watched IMSA telecast on record, averaging 398,000 viewers on Jan. 30;</span></span></span></span></li> </ul><ul> <li style="font-family: arial,helvetica,sans-serif; font-size: 12pt; margin-bottom: 11px; margin-left: 8px; text-align: justify;"><span style="font-size: 11pt;"><span style="font-family: arial,helvetica,sans-serif;"><span style="font-size: 12pt;"><span style="font-family: times new roman,times;">Season-long viewership on NBCSN was up 3% vs. 2020, averaging 179,000 viewers.</span></span></span></span></li> </ul><p style="text-align: justify; margin-bottom: 11px;"><span style="font-size: 11pt;"><span style="font-family: arial,helvetica,sans-serif;"><span style="font-size: 12pt;"><span style="font-family: times new roman,times;">NBC Sports’ IMSA coverage joins its NASCAR and INDYCAR presentations in producing viewership gains in 2021. </span></span><a ondragstart="return false;" style="color: #0563c1; text-decoration: underline;" href="https://u7061146.ct.sendgrid.net/ls/click?upn=4tNED-2FM8iDZJQyQ53jATUa0KOn1rB1Q7DkTRbJ1htgCwBFwNwnUQveT2dvyBuEvtHyxDWP-2FPUA9iunahjkfvgFOa0Mnl9d0cgFobhbnNtAik56qJuX4F8SijnfKKSV1rDLVvux8xmNytZrjee-2FWJW2MImOnSrtegeUStMc8MnV7fJk01mFno2C5euFjiatAC9AP8_91xBg-2F4IzffZb6vjWsCSMxiugbz9jTPLKSP3qQvckGoWso5wn8LDdlgLmZWCA1YIWhi6fA3M36idwxNnvHHy9wX4bJAw6MfSC8DpjK7UPeQWjoBmBEiMyfB7MO6EIC0ztiRTPXMa-2Bgy0j8VQ8dR0xBdQx8feLIaIgEyg8bndH3ZZLz18NilDxWuBGuncwLbVZCaGm1lC488tcftnWYNCjKgkM2A52HVU9AMM6Gk8nsrVlmm2-2BEIvbNW0coavkd1SIDR39Frr1veBmgrC-2Bl6-2FAZUX7sutwoi4Q2DBgkPkBvA58jMQj9iaHRrQ8hvkgB-2Fm4x2oe4CPsCoe6Cd9MkIvs9elvhn-2FBrQdkdLGoDy-2BZ9s-3D" target="_blank" rel="noopener noreferrer" data-saferedirecturl="https://www.google.com/url?q=https://u7061146.ct.sendgrid.net/ls/click?upn%3D4tNED-2FM8iDZJQyQ53jATUa0KOn1rB1Q7DkTRbJ1htgCwBFwNwnUQveT2dvyBuEvtHyxDWP-2FPUA9iunahjkfvgFOa0Mnl9d0cgFobhbnNtAik56qJuX4F8SijnfKKSV1rDLVvux8xmNytZrjee-2FWJW2MImOnSrtegeUStMc8MnV7fJk01mFno2C5euFjiatAC9AP8_91xBg-2F4IzffZb6vjWsCSMxiugbz9jTPLKSP3qQvckGoWso5wn8LDdlgLmZWCA1YIWhi6fA3M36idwxNnvHHy9wX4bJAw6MfSC8DpjK7UPeQWjoBmBEiMyfB7MO6EIC0ztiRTPXMa-2Bgy0j8VQ8dR0xBdQx8feLIaIgEyg8bndH3ZZLz18NilDxWuBGuncwLbVZCaGm1lC488tcftnWYNCjKgkM2A52HVU9AMM6Gk8nsrVlmm2-2BEIvbNW0coavkd1SIDR39Frr1veBmgrC-2Bl6-2FAZUX7sutwoi4Q2DBgkPkBvA58jMQj9iaHRrQ8hvkgB-2Fm4x2oe4CPsCoe6Cd9MkIvs9elvhn-2FBrQdkdLGoDy-2BZ9s-3D&amp;source=gmail&amp;ust=1638562616676000&amp;usg=AOvVaw3qx98v7ewNF4QXSmYNvmm2"><span style="font-size: 12pt;"><span style="font-family: times new roman,times;">The 2021 NASCAR Cup and Xfinity Series produced year-over-year viewership increases</span></span></a><span style="font-size: 12pt;"><span style="font-family: times new roman,times;"> and NBC Sports’ most-streamed seasons for both series on record. </span></span><a ondragstart="return false;" style="color: #0563c1; text-decoration: underline;" href="https://u7061146.ct.sendgrid.net/ls/click?upn=4tNED-2FM8iDZJQyQ53jATUa0KOn1rB1Q7DkTRbJ1htgCwBFwNwnUQveT2dvyBuEvt8RdKJwE1vT3YbRdi2lVRN-2BG4Hqrq7uH8CKlzA1mSdBRUw2b8UbnjYPsXjxJgaDbxNpQJhcSteETxY-2FA5FseRagTWUwqISPfYLW002-2BTeh54-3Dxp4n_91xBg-2F4IzffZb6vjWsCSMxiugbz9jTPLKSP3qQvckGoWso5wn8LDdlgLmZWCA1YIWhi6fA3M36idwxNnvHHy9wX4bJAw6MfSC8DpjK7UPeQWjoBmBEiMyfB7MO6EIC0ztiRTPXMa-2Bgy0j8VQ8dR0xBdQx8feLIaIgEyg8bndH3ZZLz18NilDxWuBGuncwLbVZCaGm1lC488tcftnWYNCjCU5rnSKC-2B3-2FqdtJtQ64x-2BHIfLPh5DPDIuwqhEXrD6XhIjhI5QevmXmSkvTPWizuHXOZzY7KkMwNhmgGhzXymMCKYje5EGW8XOlPXve-2B8ZeklFwCJRAp2RjaSn0vPuEJT5I6qA-2BhlPbdTTKzA8DXPW4-3D" target="_blank" rel="noopener noreferrer" data-saferedirecturl="https://www.google.com/url?q=https://u7061146.ct.sendgrid.net/ls/click?upn%3D4tNED-2FM8iDZJQyQ53jATUa0KOn1rB1Q7DkTRbJ1htgCwBFwNwnUQveT2dvyBuEvt8RdKJwE1vT3YbRdi2lVRN-2BG4Hqrq7uH8CKlzA1mSdBRUw2b8UbnjYPsXjxJgaDbxNpQJhcSteETxY-2FA5FseRagTWUwqISPfYLW002-2BTeh54-3Dxp4n_91xBg-2F4IzffZb6vjWsCSMxiugbz9jTPLKSP3qQvckGoWso5wn8LDdlgLmZWCA1YIWhi6fA3M36idwxNnvHHy9wX4bJAw6MfSC8DpjK7UPeQWjoBmBEiMyfB7MO6EIC0ztiRTPXMa-2Bgy0j8VQ8dR0xBdQx8feLIaIgEyg8bndH3ZZLz18NilDxWuBGuncwLbVZCaGm1lC488tcftnWYNCjCU5rnSKC-2B3-2FqdtJtQ64x-2BHIfLPh5DPDIuwqhEXrD6XhIjhI5QevmXmSkvTPWizuHXOZzY7KkMwNhmgGhzXymMCKYje5EGW8XOlPXve-2B8ZeklFwCJRAp2RjaSn0vPuEJT5I6qA-2BhlPbdTTKzA8DXPW4-3D&amp;source=gmail&amp;ust=1638562616676000&amp;usg=AOvVaw3gDjEO4mY0u-pr2H5Ttd1y"><span style="font-size: 12pt;"><span style="font-family: times new roman,times;">The 2021 NTT INDYCAR SERIES delivered NBC Sports’ most-watched INDYCAR season on record</span></span></a><span style="font-size: 12pt;"><span style="font-family: times new roman,times;"> and INDYCAR’s best combined broadcast/cable viewership for the series in five years.</span></span></span></span></p><p style="text-align: justify; margin-bottom: 11px;"><span style="font-size: 11pt;">NBC Sports PR</span></p></div><div class="clr"></div><div class="itemToolbarContent"><div class="itemRatingBlock"> <span>Rate this item</span> <div class="itemRatingForm"><ul class="itemRatingList"> <li class="itemCurrentRating" id="itemCurrentRating66263" style="width:0%;"></li> <li><a ondragstart="return false;" href="#" data-id="66263" title="1 star out of 5" class="one-star">1</a></li> <li><a ondragstart="return false;" href="#" data-id="66263" title="2 stars out of 5" class="two-stars">2</a></li> <li><a ondragstart="return false;" href="#" data-id="66263" title="3 stars out of 5" class="three-stars">3</a></li> <li><a ondragstart="return false;" href="#" data-id="66263" title="4 stars out of 5" class="four-stars">4</a></li> <li><a ondragstart="return false;" href="#" data-id="66263" title="5 stars out of 5" class="five-stars">5</a></li> </ul><div id="itemRatingLog66263" class="itemRatingLog">(0 votes)</div><div class="clr"></div></div><div class="clr"></div></div><div class="itemToolbar float-right"><ul> <li> <span class="itemTextResizerTitle">font size</span> <a ondragstart="return false;" href="#" id="fontDecrease"> <span>decrease font size</span> </a> <a ondragstart="return false;" href="#" id="fontIncrease"> <span>increase font size</span> </a> </li> <li> <a ondragstart="return false;" class="itemPrintLink" rel="nofollow" href="/index.php/news/racing-news/66263-imsa-weathertech-championship-on-nbc-sports-produces-significant-viewership-gains-for-third-consecutive-year?tmpl=component&amp;print=1" onclick="window.open(this.href,'printWindow','width=900,height=600,location=no,menubar=no,resizable=yes,scrollbars=yes'); return false;"> <span>Print</span> </a> </li> <li> <a ondragstart="return false;" class="itemEmailLink" rel="nofollow" href="/index.php/component/mailto/?tmpl=component&amp;template=ts_newslinen&amp;link=e07b7de25bbdc03656a1196da033e2f691f74a39" onclick="window.open(this.href,'emailWindow','width=400,height=350,location=no,menubar=no,resizable=no,scrollbars=no'); return false;"> <span>Email</span> </a> </li> </ul><div class="clr"></div></div></div><div class="itemContentFooter"><div class="clr"></div></div><div class="clr"></div></div><div class="itemSocialSharing"><div class="itemTwitterButton"> <a ondragstart="return false;" href="https://twitter.com/share" class="twitter-share-button" data-lang="en-gb" data-via="">Tweet</a> <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document,'script','twitter-wjs');</script> </div><div class="itemFacebookButton"><div id="fb-root"></div> <script>(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(d.getElementById(id))return;js=d.createElement(s);js.id=id;js.src="//connect.facebook.net/en_GB/sdk.js#xfbml=1&version=v2.5";fjs.parentNode.insertBefore(js,fjs);}(document,'script','facebook-jssdk'));</script><div class="fb-like" data-width="200" data-layout="button_count" data-action="like" data-show-faces="false" data-share="false"></div></div><div class="clr"></div></div><div class="itemLinks"><div class="clr"></div></div><div class="itemNavigation"> <a ondragstart="return false;" class="itemPrevious" href="/index.php/news/racing-news/66262-nascar-flosports-announce-landmark-streaming-partnership">&laquo; NASCAR, FloSports Announce Landmark Streaming Partnership</a> </div><div class="itemAuthorBlock"> <img ondragstart="return false;" class="itemAuthorAvatar jch-lazyload" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxIiBoZWlnaHQ9IjEiPjwvc3ZnPg==" data-src="/media/k2/users/13.png" alt="Speedway Digest Staff" /><noscript><img ondragstart="return false;" class="itemAuthorAvatar" src="/media/k2/users/13.png" alt="Speedway Digest Staff" /></noscript><div class="itemAuthorDetails"><h3 class="itemAuthorName"> <a ondragstart="return false;" rel="author" href="/index.php/news/racing-news/author/1069-speedwaydigeststaff">Speedway Digest Staff</a> </h3><p><p>Follow us on Twitter <a ondragstart="return false;" href="https://www.twitter.com/speedwaydigest">@SpeedwayDigest</a></p></p><div class="clr"></div><div class="clr"></div></div><div class="clr"></div></div><div class="itemAuthorLatest"><h3>Latest from Speedway Digest Staff</h3><ul> <li class="even"> <a ondragstart="return false;" href="/index.php/news/nascar-cup-series-news/66266-hooters-extends-sponsorship-of-chase-elliott-for-three-more-seasons-external">Hooters extends sponsorship of Chase Elliott for three more seasons External</a> </li> <li class="odd"> <a ondragstart="return false;" href="/index.php/news/speedway-news/66265-world-wide-technology-raceway-owner-and-ceo-curtis-francois-to-receive-jack-buck-award-on-december-6">World Wide Technology Raceway owner and CEO Curtis Francois to receive Jack Buck Award on December 6</a> </li> <li class="even"> <a ondragstart="return false;" href="/index.php/news/racing-news/66262-nascar-flosports-announce-landmark-streaming-partnership">NASCAR, FloSports Announce Landmark Streaming Partnership</a> </li> <li class="odd"> <a ondragstart="return false;" href="/index.php/news/racing-news/66261-jake-griffin-makes-inaugural-appearance-at-castrol-gateway-dirt-nationals-in-the-open-wheeled-modified-division">Jake Griffin makes inaugural appearance at CASTROL GATEWAY DIRT NATIONALS in the open wheeled modified division.</a> </li> <li class="even"> <a ondragstart="return false;" href="/index.php/news/speedway-news/66260-record-broken-lucas-oil-tulsa-shootout-smashes-entry-record">RECORD BROKEN! Lucas Oil Tulsa Shootout Smashes Entry Record</a> </li> </ul><div class="clr"></div></div><div class="clr"></div><div class="itemBackToTop"> <a ondragstart="return false;" class="k2Anchor" href="/index.php/news/racing-news/66263-imsa-weathertech-championship-on-nbc-sports-produces-significant-viewership-gains-for-third-consecutive-year#startOfPageId66263"> back to top </a> </div><div class="clr"></div></div></div></main><aside id="sp-right" class="col-lg-4 "><div class="sp-column "><div class="sp-module "><div class="sp-module-content"><div class="custom"> <center><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-4983971213106691" data-ad-slot="1381625561" data-ad-format="auto" data-full-width-responsive="true"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></center></div></div></div><div class="sp-module "><div class="sp-module-content"><div class="custom"> <center><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-4983971213106691" data-ad-slot="1381625561" data-ad-format="auto" data-full-width-responsive="true"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></center></div></div></div></div></aside></div></div></div></section><footer id="sp-footer" class="ts-footer"><div class="row"><div id="sp-footer1" class="col-lg-6 "><div class="sp-column text-center"><span class="sp-copyright">Copyright © 2010 - 2021 STS Motorsports Inc. All Rights Reserved.</span></div></div><div id="sp-footer2" class="col-lg-6 "><div class="sp-column "><div class="sp-module "><div class="sp-module-content"><ul class="menu nav-pills"> <li class="item-1557"><a ondragstart="return false;" href="/index.php/advertise">Advertise</a></li><li class="item-1559"><a ondragstart="return false;" href="/index.php/privacy-policy">Privacy Policy</a></li><li class="item-1621"><a ondragstart="return false;" href="/index.php/sitemap">Sitemap</a></li><li class="item-1558"><a ondragstart="return false;" href="/index.php/sd-staff">SD Staff</a></li><li class="item-1576"><a ondragstart="return false;" href="/index.php/writer-login">Writer Login</a></li></ul></div></div></div></div></div></footer></div></div><div class="offcanvas-overlay"></div><div class="offcanvas-menu"> <a ondragstart="return false;" href="#" class="close-offcanvas"><span class="fa fa-remove"></span></a> <div class="offcanvas-inner"><div class="sp-module "><div class="sp-module-content"><ul class="menu"> <li class="item-241 default"><a ondragstart="return false;" href="/index.php">Home</a></li><li class="item-186 active menu-deeper menu-parent"><a ondragstart="return false;" href="/index.php/news">News<span class="menu-toggler"></span></a><ul class="menu-child"><li class="item-205"><a ondragstart="return false;" href="/index.php/news/nascar-cup-series-news">NASCAR Cup Series News</a></li><li class="item-188"><a ondragstart="return false;" href="/index.php/news/xfinity-series-news">Xfinity Series News</a></li><li class="item-1922"><a ondragstart="return false;" href="/index.php/news/nascar-truck-series-news">NASCAR Truck Series News</a></li><li class="item-190"><a ondragstart="return false;" href="/index.php/news/speedway-news">Speedway News</a></li><li class="item-207 current active"><a ondragstart="return false;" href="/index.php/news/racing-news">Racing News</a></li><li class="item-2153"><a ondragstart="return false;" href="/index.php/news/eracing-news">eRacing News</a></li><li class="item-1876"><a ondragstart="return false;" href="/index.php/news/latest-news">Latest News</a></li></ul></li><li class="item-197 menu-deeper menu-parent"><a ondragstart="return false;" href="/index.php/nascar-schedules">Schedules<span class="menu-toggler"></span></a><ul class="menu-child"><li class="item-198"><a ondragstart="return false;" href="/index.php/nascar-schedules/nascar-cup-series-schedule">NASCAR Cup Series Schedule</a></li><li class="item-199"><a ondragstart="return false;" href="/index.php/nascar-schedules/xfinity-series-schedule">Xfinity Series Schedule</a></li><li class="item-200"><a ondragstart="return false;" href="/index.php/nascar-schedules/nascar-truck-series-schedule">NASCAR Truck Series Schedule</a></li><li class="item-202"><a ondragstart="return false;" href="/index.php/nascar-schedules/weekend-schedule">Weekend Schedule</a></li></ul></li><li class="item-208 menu-deeper menu-parent"><a ondragstart="return false;" href="/index.php/point-standings">Point Standings<span class="menu-toggler"></span></a><ul class="menu-child"><li class="item-209"><a ondragstart="return false;" href="/index.php/point-standings/nascar-cup-series">NASCAR Cup Series</a></li><li class="item-210"><a ondragstart="return false;" href="/index.php/point-standings/xfinity-series">Xfinity Series</a></li><li class="item-211"><a ondragstart="return false;" href="/index.php/point-standings/nascar-truck-series">NASCAR Truck Series</a></li></ul></li><li class="item-204 menu-deeper menu-parent"><a ondragstart="return false;" href="/index.php/scanner-frequencies">Scanner Frequencies<span class="menu-toggler"></span></a><ul class="menu-child"><li class="item-235"><a ondragstart="return false;" href="/index.php/scanner-frequencies/nascar-cup-series-frequencies">NASCAR Cup Series Frequencies</a></li><li class="item-236"><a ondragstart="return false;" href="/index.php/scanner-frequencies/xfinity-frequencies">Xfinity Frequencies</a></li><li class="item-237"><a ondragstart="return false;" href="/index.php/scanner-frequencies/nascar-truck-series-frequencies">NASCAR Truck Series Frequencies</a></li><li class="item-1596"><a ondragstart="return false;" href="/index.php/scanner-frequencies/arca-series-frequencies">ARCA Series Frequencies </a></li></ul></li><li class="item-606"><a ondragstart="return false;" href="/index.php/writers-wanted">Writers Wanted</a></li></ul></div></div></div></div> <a ondragstart="return false;" href="#" class="sp-scroll-up" aria-label="Scroll Up"><span class="fa fa-chevron-up" aria-hidden="true"></span></a> <amp-ad width="100vw" height="320" type="adsense" data-ad-client="ca-pub-4983971213106691" data-ad-slot="1381625561" data-auto-format="rspv" data-full-width=""><div overflow=""></div></amp-ad><div id="openModal" class="modalDialog"><div> <a ondragstart="return false;" href="#close" title="Close" id="close" class="close">X</a> <h2>No right click</h2><p>Please link the article. </p></div></div> <script type="text/javascript">disableSelection(document.body)</script> </body> </html>