<!DOCTYPE html>
<!--[if lt IE 7]>      <html prefix="og: http://ogp.me/ns#" class="no-js lt-ie9 lt-ie8 lt-ie7"  lang="en-gb"> <![endif]-->
<!--[if IE 7]>         <html prefix="og: http://ogp.me/ns#" class="no-js lt-ie9 lt-ie8"  lang="en-gb"> <![endif]-->
<!--[if IE 8]>         <html prefix="og: http://ogp.me/ns#" class="no-js lt-ie9"  lang="en-gb"> <![endif]-->
<!--[if gt IE 8]><!--> <html prefix="og: http://ogp.me/ns#" class="no-js" lang="en-gb"> <!--<![endif]-->
<head>
<script type="text/javascript">  (function(){    function blockCookies(disableCookies, disableLocal, disableSession){    if(disableCookies == 1){    if(!document.__defineGetter__){    Object.defineProperty(document, 'cookie',{    get: function(){ return ''; },    set: function(){ return true;}    });    }else{    var oldSetter = document.__lookupSetter__('cookie');    if(oldSetter) {    Object.defineProperty(document, 'cookie', {    get: function(){ return ''; },    set: function(v){    if(v.match(/reDimCookieHint\=/)) {    oldSetter.call(document, v);    }    return true;    }    });    }    }    var cookies = document.cookie.split(';');    for (var i = 0; i < cookies.length; i++) {    var cookie = cookies[i];    var pos = cookie.indexOf('=');    var name = '';    if(pos > -1){    name = cookie.substr(0, pos);    }else{    name = cookie;    }    if(name.match(/reDimCookieHint/)) {    document.cookie = name + '=; expires=Thu, 01 Jan 1970 00:00:00 GMT';    }    }    }    if(disableLocal == 1){    window.localStorage.clear();    window.localStorage.__proto__ = Object.create(window.Storage.prototype);    window.localStorage.__proto__.setItem = function(){ return undefined; };    }    if(disableSession == 1){    window.sessionStorage.clear();    window.sessionStorage.__proto__ = Object.create(window.Storage.prototype);    window.sessionStorage.__proto__.setItem = function(){ return undefined; };    }    }    blockCookies(1,1,1);    }()); </script>
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
<base href="https://speedwaydigest.com/index.php/news/nascar-cup-series-news/54078-corey-lajoie-set-for-second-season-with-go-fas-racing" />
<meta http-equiv="content-type" content="text/html; charset=utf-8" />
<meta name="keywords" content="NASCAR, NASCAR News, NASCAR Drivers, NASCAR Frequencies, Monster Cup, XFINITY, Camping World, NASCAR Points, Speedway Digest, Speedway Digest NASCAR News, Daytona, Richmond, Martinsville, Dover, Charlotte, Darlington, North Wilkesboro, Texas Motor Speedway, Pocono Speedway, Watkins Glen, Auto Club Speedway, Bristol Motor Speedway, Kansas Speedway, Talladega Superspeedway, Atlanta Motor Speedway, News, Jimmie Johnson, Roush Racing, Hendricks Motorsports, BK Racing, Wood Brothers Racing, Richard Petty Motorsports, Yates Racing, Robert Yates Racing, Michael Waltrip Racing, Carl Edwards, Trevor Bayne, Save The Speedway, North Wilkesboro Speedway, Dale Earnhardt, Dale Earnhardt Jr., NASCAR Frequencies, Monster Energy NASCAR Cup Series, Monster Energy Series, XFINITY Series, Camping World Truck Series, Las Vegas Motor Speedway, Phoenix International Raceway, Charlotte Motor Speedway, New Hampshire Motor Speedway, Gateway Motorsports Park, Darlington Raceway, Ryan Blaney, Chase Elliott, Ford Performance, Team Chevy, Toyota Racing, Kyle Busch, Kurt Busch, Denny Hamlin, NASCAR schedule, nascar race today, nascar race schedule, nascar race results, nascar race this weekend, nascar race results today, nascar truck race, nascar trucks, where is the nascar race today, nascar xfinity race, nascar schedule, nascar news, daytona 500, nascar race today, nascar today, nascar race, nascar results, nascar race schedule, nascar live" />
<meta name="rights" content="Copyright - Steven B. Wilson - STS Motorsports Inc. 2005 - 2019" />
<meta name="author" content="Speedway Digest Staff" />
<meta property="og:url" content="https://speedwaydigest.com/index.php/news/nascar-cup-series-news/54078-corey-lajoie-set-for-second-season-with-go-fas-racing" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Corey LaJoie set for second season with Go Fas Racing" />
<meta property="og:description" content="Go Fas Racing (GFR) is proud to announce that they have re-signed Corey LaJoie to continue as the driver of the No. 32 Ford Mustang for the 2020 NASCAR Cup Series season. Both LaJoie and GFR are prepared to continue the year-to-year improvement of their program beginning with the 62nd running of the..." />
<meta property="og:image" content="https://speedwaydigest.com/media/k2/items/cache/5e4a7c3d50ac4934706e9dd787c4fd63_L.jpg" />
<meta name="image" content="https://speedwaydigest.com/media/k2/items/cache/5e4a7c3d50ac4934706e9dd787c4fd63_L.jpg" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:site" content="@speedwaydigest" />
<meta name="twitter:title" content="Corey LaJoie set for second season with Go Fas Racing" />
<meta name="twitter:description" content="Go Fas Racing (GFR) is proud to announce that they have re-signed Corey LaJoie to continue as the driver of the No. 32 Ford Mustang for the 2020 NASCAR Cup Series season. Both LaJoie and GFR are prepa..." />
<meta name="twitter:image" content="https://speedwaydigest.com/media/k2/items/cache/5e4a7c3d50ac4934706e9dd787c4fd63_M.jpg" />
<meta name="twitter:image:alt" content="Corey LaJoie set for second season with Go Fas Racing" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="description" content="Go Fas Racing (GFR) is proud to announce that they have re-signed Corey LaJoie to continue as the driver of the No. 32 Ford Mustang for the 2020 NASCA..." />
<title>Corey LaJoie set for second season with Go Fas Racing</title>
<link href="/index.php/news/nascar-cup-series-news/54078-corey-lajoie-set-for-second-season-with-go-fas-racing" rel="canonical" />
<link href="https://speedwaydigest.com/index.php/news/nascar-cup-series-news/54078-corey-lajoie-set-for-second-season-with-go-fas-racing/amp" rel="amphtml" />
<link href="/templates/ts_newsline/favicon.ico" rel="shortcut icon" type="image/vnd.microsoft.icon" />
<link href="https://cdn.jsdelivr.net/npm/magnific-popup@1.1.0/dist/magnific-popup.min.css" rel="stylesheet" type="text/css" />
<link href="https://cdn.jsdelivr.net/npm/simple-line-icons@2.4.1/css/simple-line-icons.css" rel="stylesheet" type="text/css" />
<link href="/templates/ts_newsline/css/k2.css?v=2.10.1" rel="stylesheet" type="text/css" />
<link href="/media/plg_content_osembed/css/osembed.css?1b788910084a352c4fad4dd7fc2133a9" rel="stylesheet" type="text/css" />
<link href="/templates/ts_newsline/css/bootstrap.min.css" rel="stylesheet" type="text/css" />
<link href="/templates/ts_newsline/css/bootstrap-responsive.min.css" rel="stylesheet" type="text/css" />
<link href="/plugins/system/helix/css/font-awesome.css" rel="stylesheet" type="text/css" />
<link href="//fonts.googleapis.com/css?family=Droid+Serif:400,700" rel="stylesheet" type="text/css" />
<link href="/templates/ts_newsline/css/mobile-menu.css" rel="stylesheet" type="text/css" />
<link href="/templates/ts_newsline/css/template.css" rel="stylesheet" type="text/css" />
<link href="/templates/ts_newsline/css/presets/preset2.css" rel="stylesheet" type="text/css" />
<link href="/modules/mod_sp_news_highlighter/assets/css/style.css" rel="stylesheet" type="text/css" />
<link href="/plugins/system/cookiehint/css/black.css?971addf5a774cd28a0d9c5ae1c879517" rel="stylesheet" type="text/css" />
<style type="text/css">

                        /* K2 - Magnific Popup Overrides */
                        .mfp-iframe-holder {padding:10px;}
                        .mfp-iframe-holder .mfp-content {max-width:100%;width:100%;height:100%;}
                        .mfp-iframe-scaler iframe {background:#fff;padding:10px;box-sizing:border-box;box-shadow:none;}
                    .container{max-width:1170px}body, p{font-family:'Droid Serif';}h1, h2, h3, h4{font-family:'Droid Serif';}
#sp-header-wrapper{padding: 0 !important; }

#sp-menu-wrapper{padding: 0 !important; }

#sp-main-body-wrapper{background: rgba(246, 180, 74, 0) !important; padding: 0 !important; }

#sp-header-wrapper{padding: 0 !important; }

#sp-menu-wrapper{padding: 0 !important; }

#sp-main-body-wrapper{background: rgba(246, 180, 74, 0) !important; padding: 0 !important; }

#sp-header-wrapper{padding: 0 !important; }

#sp-menu-wrapper{padding: 0 !important; }

#sp-main-body-wrapper{background: rgba(246, 180, 74, 0) !important; padding: 0 !important; }

#sp-footer-wrapper{padding: 0 !important; }
#sp-nh186 {color:#ffffff;background:#000000}.sp-nh-item{background:#000000}a.sp-nh-link {color:#f7fbfc}a.sp-nh-link:hover {color:#039ee1}.sp-nh-buttons,.sp-nh-item,.sp-nh-prev,.sp-nh-next {height:30px;line-height:30px}.sp-nh-prev,.sp-nh-next{background-image: url(/modules/mod_sp_news_highlighter/assets/images/style1.png)}#redim-cookiehint-bottom {position: fixed; z-index: 99999; left: 0px; right: 0px; bottom: 0px; top: auto !important;}
	</style>
<script src="/media/jui/js/jquery.min.js?971addf5a774cd28a0d9c5ae1c879517" type="text/javascript"></script>
<script src="/media/jui/js/jquery-noconflict.js?971addf5a774cd28a0d9c5ae1c879517" type="text/javascript"></script>
<script src="/media/jui/js/jquery-migrate.min.js?971addf5a774cd28a0d9c5ae1c879517" type="text/javascript"></script>
<script src="https://cdn.jsdelivr.net/npm/magnific-popup@1.1.0/dist/jquery.magnific-popup.min.js" type="text/javascript"></script>
<script src="/media/k2/assets/js/k2.frontend.js?v=2.10.1&b=20191126&sitepath=/" type="text/javascript"></script>
<script src="/media/plg_content_osembed/js/osembed.js?1b788910084a352c4fad4dd7fc2133a9" type="text/javascript"></script>
<script src="/plugins/system/helix/js/jquery-noconflict.js" type="text/javascript"></script>
<script src="/media/jui/js/bootstrap.min.js?971addf5a774cd28a0d9c5ae1c879517" type="text/javascript"></script>
<script src="/plugins/system/helix/js/modernizr-2.6.2.min.js" type="text/javascript"></script>
<script src="/plugins/system/helix/js/helix.core.js" type="text/javascript"></script>
<script src="/plugins/system/helix/js/menu.js" type="text/javascript"></script>
<script src="/templates/ts_newsline/js/main.js" type="text/javascript"></script>
<script src="/templates/ts_newsline/js/jquery.placeholder.js" type="text/javascript"></script>
<script src="/modules/mod_sp_news_highlighter/assets/js/sp_highlighter.js" type="text/javascript"></script>
<script type="application/ld+json">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</script>
<script type="text/javascript">
spnoConflict(function($){

					function mainmenu() {
						$('.sp-menu').spmenu({
							startLevel: 0,
							direction: 'ltr',
							initOffset: {
								x: 0,
								y: 0
							},
							subOffset: {
								x: 0,
								y: 10
							},
							center: 0
						});
			}

			mainmenu();

			$(window).on('resize',function(){
				mainmenu();
			});


			});
	</script>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-4983971213106691",
          enable_page_level_ads: true
     });
</script>
<script async custom-element="amp-ad" src="https://cdn.ampproject.org/v0/amp-ad-0.1.js"></script>
<script async custom-element="amp-auto-ads" src="https://cdn.ampproject.org/v0/amp-auto-ads-0.1.js">
</script>
<script async="async" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-7741304783035041",
    enable_page_level_ads: true
  });
</script>
<style type="text/css"> @media print { body { display:none } } </style>
<script type="text/javascript">
	function clickExplorer() {
		if( document.all ) {
			alert('Play nice and link the article. Thanks.');
		}
		return false;
	}
	function clickOther(e) {
		if( document.layers || ( document.getElementById && !document.all ) ) {
			if ( e.which == 2 || e.which == 3 ) {
				alert('Play nice and link the article. Thanks.');
				return false;
			}
		}
	}
	if( document.layers ) {
		document.captureEvents( Event.MOUSEDOWN );
		document.onmousedown=clickOther;
	}
	else {
		document.onmouseup = clickOther;
		document.oncontextmenu = clickExplorer;
	}
</script>
<script type="text/javascript">
	function disableSelection(target){
	if (typeof target.onselectstart!="undefined") // IE
		target.onselectstart=function(){return false}
	else if (typeof target.style.MozUserSelect!="undefined") // Firefox
		target.style.MozUserSelect="none"
	else // Opera etc
		target.onmousedown=function(){return false}
	target.style.cursor = "default"
	}
</script>
<script type="text/javascript">
	/* <![CDATA[ */
		window.addEvent('domready', function() {
			document.body.oncopy = function() {
				alert('Play nice and link the article. Thanks.');
				return false;
			}
		});
	/* ]]> */
</script>
<meta http-equiv="imagetoolbar" content="no">
</head>
<body class="item subpage  ltr preset2 menu-nascar-cup-series-news responsive bg hfeed clearfix">
<div class="body-innerwrapper">
<!--[if lt IE 8]>
        <div class="chromeframe alert alert-danger" style="text-align:center">You are using an <strong>outdated</strong> browser. Please <a ondragstart="return false;" target="_blank" href="http://browsehappy.com/">upgrade your browser</a> or <a ondragstart="return false;" target="_blank" href="http://www.google.com/chromeframe/?redirect=true">activate Google Chrome Frame</a> to improve your experience.</div>
        <![endif]-->
<section id="sp-top-bar-wrapper" class=" "><div class="container"><div class="row-fluid" id="top-bar">
<div id="sp-top-bar1" class="span9 hidden-phone hidden-tablet"><div class="module ">
<div class="mod-wrapper clearfix">
<div class="mod-content clearfix">
<div class="mod-inner clearfix">
<script type="text/javascript">
	jQuery(function($) {
		$('#sp-nh186').spNewsHighlighter({
			'interval': 5000,
            'fxduration': 1000,
            'animation': "slide-vertical"
		});
	});
</script>
<div id="sp-nh186" class="sp_news_higlighter">
<div class="sp-nh-buttons">
<span class="sp-nh-text">Headline News</span>
<div id="sp-nh-prev186" class="sp-nh-prev"></div>
<div id="sp-nh-next186" class="sp-nh-next"></div>
</div>
<div id="sp-nh-items186" class="sp-nh-item">
<div class="sp-nh-item">
<a ondragstart="return false;" class="sp-nh-link" href="/index.php/news/nascar-cup-series-news/54091-raise-your-cans-busch-beer-wins-nascar-marketing-achievement-award"><span class="sp-nh-title">Raise Your Cans: Busch Beer Wins NASCAR Marketing Achievement Award</span> - <span class="sp-nh-date">Wednesday, 04 December 2019 16:06</span></a>
</div>
<div class="sp-nh-item">
<a ondragstart="return false;" class="sp-nh-link" href="/index.php/news/xfinity-series-news/54090-allgaier-continues-jrm-dominance-of-nascar-xfinity-series-most-popular-driver-award"><span class="sp-nh-title">Allgaier Continues JRM Dominance of NASCAR Xfinity Series Most Popular Driver Award</span> - <span class="sp-nh-date">Wednesday, 04 December 2019 15:50</span></a>
</div>
<div class="sp-nh-item">
<a ondragstart="return false;" class="sp-nh-link" href="/index.php/news/racing-news/54089-the-viroc-gets-revamped-for-2020-lucas-oil-chili-bowl-nationals-presented-by-general-tire"><span class="sp-nh-title">The VIROC Gets Revamped For 2020 Lucas Oil Chili Bowl Nationals Presented by General Tire</span> - <span class="sp-nh-date">Wednesday, 04 December 2019 15:20</span></a>
</div>
<div class="sp-nh-item">
<a ondragstart="return false;" class="sp-nh-link" href="/index.php/news/speedway-news/54088-take-advantage-of-40-food-city-500-tickets-at-all-food-city-locations-through-dec-31"><span class="sp-nh-title">Take advantage of $40 Food City 500 tickets at all Food City locations through Dec. 31</span> - <span class="sp-nh-date">Wednesday, 04 December 2019 14:16</span></a>
</div>
<div class="sp-nh-item">
<a ondragstart="return false;" class="sp-nh-link" href="/index.php/news/racing-news/54087-lucas-oil-chili-bowl-nationals-coming-to-lortv-this-january"><span class="sp-nh-title">Lucas Oil Chili Bowl Nationals Coming to LORTV This January</span> - <span class="sp-nh-date">Wednesday, 04 December 2019 13:53</span></a>
</div>
</div>
<div style="clear:both"></div>
</div> </div>
</div>
</div>
</div>
<div class="gap"></div>
</div>
<div id="sp-top-bar2" class="span3 visible-desktop"><div class="module ">
<div class="mod-wrapper clearfix">
<div class="mod-content clearfix">
<div class="mod-inner clearfix">
<div class="custom">
<p><span class="top-social"> <a ondragstart="return false;" class="hasTip" title="Facebook" href="https://www.facebook.com/speedwaydigest" rel="alternate"><i style="" class="icon-facebook "></i></a> <a ondragstart="return false;" class="hasTip" title="Twitter" href="https://www.twitter.com/speedwaydigest" rel="alternate"><i style="" class="icon-twitter "></i></a> <a ondragstart="return false;" class="hasTip" title="Google+" href="https://plus.google.com/+Speedwaydigest" rel="alternate"><i style="" class="icon-google-plus "></i></a><a ondragstart="return false;" class="hasTip" title="RSS" href="/index.php/news/latest-news?format=feed" rel="alternate"><i style="" class="icon-rss "></i></a> </span></p></div>
</div>
</div>
</div>
</div>
<div class="gap"></div>
</div>
</div></div></section><header id="sp-header-wrapper" class=" "><div class="container"><div class="row-fluid" id="header">
<div id="sp-logo" class="span4"><div class="logo-wrapper"><a ondragstart="return false;" href="/"><img ondragstart="return false;" alt="" class="image-logo" src="/images/sdlogoweb.fw.png" /></a></div></div>
<div id="sp-ad1" class="span8 hidden-phone hidden-tablet"><div class="module ">
<div class="mod-wrapper clearfix">
<div class="mod-content clearfix">
<div class="mod-inner clearfix">
<div class="custom">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-4983971213106691" data-ad-slot="7293211960"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
</div>
</div>
</div>
</div>
<div class="gap"></div>
</div>
</div></div></header><section id="sp-menu-wrapper" class=" "><div class="container"><div class="row-fluid" id="menu">
<div id="sp-menu" class="span9">
<div id="sp-main-menu" class="visible-desktop">
<ul class="sp-menu level-0"><li class="menu-item first"><a ondragstart="return false;" href="https://speedwaydigest.com/" class="menu-item first"><span class="menu"><span class="menu-title">Home</span></span></a></li><li class="menu-item active parent "><a ondragstart="return false;" href="/index.php/news" class="menu-item active parent "><span class="menu"><span class="menu-title">News</span></span></a><div class="sp-submenu"><div class="sp-submenu-wrap"><div class="sp-submenu-inner clearfix" style="width: 200px;"><div class="megacol col1 first" style="width: 200px;"><ul class="sp-menu level-1"><li class="menu-item active first"><a ondragstart="return false;" href="/index.php/news/nascar-cup-series-news" class="menu-item active first"><span class="menu"><span class="menu-title">NASCAR Cup Series News</span></span></a></li><li class="menu-item"><a ondragstart="return false;" href="/index.php/news/xfinity-series-news" class="menu-item"><span class="menu"><span class="menu-title">Xfinity Series News</span></span></a></li><li class="menu-item"><a ondragstart="return false;" href="/index.php/news/nascar-truck-series-news" class="menu-item"><span class="menu"><span class="menu-title">NASCAR Truck Series News</span></span></a></li><li class="menu-item"><a ondragstart="return false;" href="/index.php/news/speedway-news" class="menu-item"><span class="menu"><span class="menu-title">Speedway News</span></span></a></li><li class="menu-item"><a ondragstart="return false;" href="/index.php/news/racing-news" class="menu-item"><span class="menu"><span class="menu-title">Racing News</span></span></a></li><li class="menu-item last"><a ondragstart="return false;" href="/index.php/news/latest-news" class="menu-item last"><span class="menu"><span class="menu-title">Latest News</span></span></a></li></ul></div></div></div></div></li><li class="menu-item parent "><a ondragstart="return false;" href="/index.php/nascar-schedules" class="menu-item parent "><span class="menu"><span class="menu-title">Schedules</span></span></a><div class="sp-submenu"><div class="sp-submenu-wrap"><div class="sp-submenu-inner clearfix" style="width: 200px;"><div class="megacol col1 first" style="width: 200px;"><ul class="sp-menu level-1"><li class="menu-item first"><a ondragstart="return false;" href="/index.php/nascar-schedules/nascar-cup-series-schedule" class="menu-item first"><span class="menu"><span class="menu-title">NASCAR Cup Series Schedule</span></span></a></li><li class="menu-item"><a ondragstart="return false;" href="/index.php/nascar-schedules/xfinity-series-schedule" class="menu-item"><span class="menu"><span class="menu-title">Xfinity Series Schedule</span></span></a></li><li class="menu-item"><a ondragstart="return false;" href="/index.php/nascar-schedules/nascar-truck-series-schedule" class="menu-item"><span class="menu"><span class="menu-title">NASCAR Truck Series Schedule</span></span></a></li><li class="menu-item last"><a ondragstart="return false;" href="/index.php/nascar-schedules/weekend-schedule" class="menu-item last"><span class="menu"><span class="menu-title">Weekend Schedule</span></span></a></li></ul></div></div></div></div></li><li class="menu-item parent "><a ondragstart="return false;" href="/index.php/point-standings" class="menu-item parent "><span class="menu"><span class="menu-title">Point Standings</span></span></a><div class="sp-submenu"><div class="sp-submenu-wrap"><div class="sp-submenu-inner clearfix" style="width: 200px;"><div class="megacol col1 first" style="width: 200px;"><ul class="sp-menu level-1"><li class="menu-item first"><a ondragstart="return false;" href="/index.php/point-standings/nascar-cup-series" class="menu-item first"><span class="menu"><span class="menu-title">NASCAR Cup Series</span></span></a></li><li class="menu-item"><a ondragstart="return false;" href="/index.php/point-standings/xfinity-series" class="menu-item"><span class="menu"><span class="menu-title">Xfinity Series</span></span></a></li><li class="menu-item last"><a ondragstart="return false;" href="/index.php/point-standings/nascar-truck-series" class="menu-item last"><span class="menu"><span class="menu-title">NASCAR Truck Series</span></span></a></li></ul></div></div></div></div></li><li class="menu-item parent "><a ondragstart="return false;" href="/index.php/scanner-frequencies" class="menu-item parent "><span class="menu"><span class="menu-title">Scanner Frequencies</span></span></a><div class="sp-submenu"><div class="sp-submenu-wrap"><div class="sp-submenu-inner clearfix" style="width: 200px;"><div class="megacol col1 first" style="width: 200px;"><ul class="sp-menu level-1"><li class="menu-item first"><a ondragstart="return false;" href="/index.php/scanner-frequencies/nascar-cup-series-frequencies" class="menu-item first"><span class="menu"><span class="menu-title">NASCAR Cup Series Frequencies</span></span></a></li><li class="menu-item"><a ondragstart="return false;" href="/index.php/scanner-frequencies/xfinity-frequencies" class="menu-item"><span class="menu"><span class="menu-title">Xfinity Frequencies</span></span></a></li><li class="menu-item"><a ondragstart="return false;" href="/index.php/scanner-frequencies/nascar-truck-series-frequencies" class="menu-item"><span class="menu"><span class="menu-title">NASCAR Truck Series Frequencies</span></span></a></li><li class="menu-item last"><a ondragstart="return false;" href="/index.php/scanner-frequencies/arca-series-frequencies" class="menu-item last"><span class="menu"><span class="menu-title">ARCA Series Frequencies </span></span></a></li></ul></div></div></div></div></li><li class="menu-item last"><a ondragstart="return false;" href="/index.php/writers-wanted" class="menu-item last"><span class="menu"><span class="menu-title">Writers Wanted</span></span></a></li></ul>
</div>
</div>
<div id="sp-search" class="span3"><div class="module ">
<div class="mod-wrapper clearfix">
<div class="mod-content clearfix">
<div class="mod-inner clearfix">
<div class="search">
<form action="/index.php/news/nascar-cup-series-news" method="post">
<input name="searchword" class="input-block-level" id="mod-search-searchword" type="text" placeholder="Search ..." />
<input type="hidden" name="task" value="search" />
<input type="hidden" name="option" value="com_search" />
<input type="hidden" name="Itemid" value="0" />
<i class="icon-search"></i>
</form>
</div>
</div>
</div>
</div>
</div>
<div class="gap"></div>
</div>
</div></div></section><section id="sp-main-body-wrapper" class=" "><div class="container"><div class="row-fluid" id="main-body">
<div id="sp-message-area" class="span8"><section id="sp-component-area-wrapper" class=" "><div class="row-fluid" id="component-area">
<div id="sp-component-area" class="span12"><section id="sp-component-wrapper"><div id="sp-component"><div id="system-message-container">
</div>

<span id="startOfPageId54078"></span>
<div id="k2Container" class="itemView">



<div class="itemBody">


<div class="itemHeader">

<h2 class="itemTitle">
Corey LaJoie set for second season with Go Fas Racing
</h2>
<div class="itemInfo">

<span class="itemDateCreated">
<i class="icon-time"></i>
03 Dec 2019 </span>

<span class="itemAuthor">
<i class="icon-user"></i>
<a ondragstart="return false;" rel="author" href="/index.php/news/nascar-cup-series-news/author/1069-speedwaydigeststaff">Speedway Digest Staff</a>
</span>
<div class="itemLinks">

<div class="itemCategory">
<i class="icon-folder-close"></i>
<a ondragstart="return false;" href="/index.php/news/nascar-cup-series-news">NASCAR Cup Series News</a>
</div>
<div class="clr"></div>
</div>
<div class="pull-right">

<span class="itemHits">
<i class="icon-eye-open"></i> 88 times </span>
</div>
</div>

</div>


<div class="itemImageBlock">
<span class="itemImage">
<a ondragstart="return false;" data-k2-modal="image" href="/media/k2/items/cache/5e4a7c3d50ac4934706e9dd787c4fd63_XL.jpg" title="Click to preview image">
<img ondragstart="return false;" src="/media/k2/items/cache/5e4a7c3d50ac4934706e9dd787c4fd63_L.jpg" alt="Corey LaJoie set for second season with Go Fas Racing" style="width:400px; height:auto;" />
</a>
</span>

<span class="itemImageCredits">NK Photography Photo</span>
<div class="clr"></div>
</div>

<div class="itemFullText">
<p>Go Fas Racing (GFR) is proud to announce that they have re-signed Corey LaJoie to continue as the driver of the No. 32 Ford Mustang for the 2020 NASCAR Cup Series season. <br /><br /> Both LaJoie and GFR are prepared to continue the year-to-year improvement of their program beginning with the 62nd running of the Daytona 500 in February with the addition of a new technical alliance with Stewart-Haas Racing. <br /><br /> "Mason [St. Hilaire] and I are excited to bring Corey back and continue Go Fas Racing's growth with 2019 being our best year ever. The Stewart-Haas Racing alliance should allow us to continue that progress throughout the 2020 season with all the great employees and marketing partners this team has! We couldn't be more excited for the 2020 season to begin," said Go Fas Racing Team Owner Archie St. Hilaire. The 28-year-old concluded his first full-time season in NASCAR's premier series in 2019 by recording career-high statistics, including two top-10 finishes and seven top-20 results in the No. 32 entry. <br /><br /> "I'm really happy that we were able to work it out so I'm able to drive the No.32 Mustang in 2020. This group is a lot of fun to go to racing with and I look forward to utilizing these SHR cars and putting together some solid runs. We had some really good finishes in 2019 and I'm excited because with the potential we have going forward, we can make 2020 an even better year," said LaJoie. <br /><br /> The Charlotte, NC native joined the organization from TriStar Motorsports after the departure of Matt DiBenedetto at the conclusion of the 2018 season. <br /><br /> Schluter Systems, Keen Parts, Superior Logistics, Drydene Performance Products, and many other great partners from 2019 will be returning to the 32 car with some exciting new partners to be announced soon. <br /><br /> GFR PR</p> </div>
<div class="clr"></div>
<div class="itemContentFooter">
<div class="clr"></div>
</div>


<div id='k2ad' style='padding:5px;text-align:center'><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-4983971213106691" data-ad-slot="3016593233"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<div class="clr"></div>
</div>


<div class="itemRatingBlock">
<span>Rate this item</span>
<div class="itemRatingForm">
<ul class="itemRatingList">
<li class="itemCurrentRating" id="itemCurrentRating54078" style="width:0%;"></li>
<li><a ondragstart="return false;" href="#" rel="54078" title="1 star out of 5" class="one-star">1</a></li>
<li><a ondragstart="return false;" href="#" rel="54078" title="2 stars out of 5" class="two-stars">2</a></li>
<li><a ondragstart="return false;" href="#" rel="54078" title="3 stars out of 5" class="three-stars">3</a></li>
<li><a ondragstart="return false;" href="#" rel="54078" title="4 stars out of 5" class="four-stars">4</a></li>
<li><a ondragstart="return false;" href="#" rel="54078" title="5 stars out of 5" class="five-stars">5</a></li>
</ul>
<div id="itemRatingLog54078" class="itemRatingLog">(0 votes)</div>
<div class="clr"></div>
</div>
<div class="clr"></div>
</div>
<div class="itemToolbar pull-right">
<ul>

<li>
<span class="itemTextResizerTitle">font size</span>
<a ondragstart="return false;" href="#" id="fontDecrease">
<span>decrease font size</span>
<img ondragstart="return false;" src="/components/com_k2/images/system/blank.gif" alt="decrease font size" />
</a>
<a ondragstart="return false;" href="#" id="fontIncrease">
<span>increase font size</span>
<img ondragstart="return false;" src="/components/com_k2/images/system/blank.gif" alt="increase font size" />
</a>
</li>

<li>
<a ondragstart="return false;" class="itemPrintLink" rel="nofollow" href="/index.php/news/nascar-cup-series-news/54078-corey-lajoie-set-for-second-season-with-go-fas-racing?tmpl=component&amp;print=1" onclick="window.open(this.href,'printWindow','width=900,height=600,location=no,menubar=no,resizable=yes,scrollbars=yes'); return false;">
<span>Print</span>
</a>
</li>

<li>
<a ondragstart="return false;" class="itemEmailLink" rel="nofollow" href="/index.php/component/mailto/?tmpl=component&amp;template=ts_newsline&amp;link=a9faf0970d69aedbe4f269418c00304b594883f8" onclick="window.open(this.href,'emailWindow','width=400,height=350,location=no,menubar=no,resizable=no,scrollbars=no'); return false;">
<span>Email</span>
</a>
</li>
</ul>
<div class="clr"></div>
</div>


<div class="item-sharing">
</div>

<div class="itemSocialSharing">

<div class="itemTwitterButton">
<a ondragstart="return false;" href="https://twitter.com/share" class="twitter-share-button" data-count="horizontal" data-via="speedwaydigest">
Tweet </a>
<script type="text/javascript" src="//platform.twitter.com/widgets.js"></script>
</div>

<div class="itemFacebookButton">
<div id="fb-root"></div>
<script type="text/javascript">
				(function(d, s, id) {
				  var js, fjs = d.getElementsByTagName(s)[0];
				  if (d.getElementById(id)) return;
				  js = d.createElement(s); js.id = id;
				  js.src = "//connect.facebook.net/en_US/all.js#xfbml=1";
				  fjs.parentNode.insertBefore(js, fjs);
				}(document, 'script', 'facebook-jssdk'));
			</script>
<div class="fb-like" data-send="false" data-width="200" data-show-faces="true"></div>
</div>
<div class="clr"></div>
</div>

<div class="itemAuthorBlock">
<img ondragstart="return false;" class="itemAuthorAvatar" src="/media/k2/users/13.png" alt="Speedway Digest Staff" />
<div class="itemAuthorDetails">
<h3 class="itemAuthorName">
<a ondragstart="return false;" rel="author" href="/index.php/news/nascar-cup-series-news/author/1069-speedwaydigeststaff">Speedway Digest Staff</a>
</h3>
<p><p>Follow us on Twitter <a ondragstart="return false;" href="https://www.twitter.com/speedwaydigest">@SpeedwayDigest</a></p></p>
<div class="clr"></div>

</div>
<div class="clr"></div>
</div>

<div class="itemAuthorLatest">
<h3>Latest from Speedway Digest Staff</h3>
<ul>
<li class="even">
<a ondragstart="return false;" href="/index.php/news/nascar-cup-series-news/54091-raise-your-cans-busch-beer-wins-nascar-marketing-achievement-award">Raise Your Cans: Busch Beer Wins NASCAR Marketing Achievement Award</a>
</li>
<li class="odd">
<a ondragstart="return false;" href="/index.php/news/xfinity-series-news/54090-allgaier-continues-jrm-dominance-of-nascar-xfinity-series-most-popular-driver-award">Allgaier Continues JRM Dominance of NASCAR Xfinity Series Most Popular Driver Award</a>
</li>
<li class="even">
<a ondragstart="return false;" href="/index.php/news/racing-news/54089-the-viroc-gets-revamped-for-2020-lucas-oil-chili-bowl-nationals-presented-by-general-tire">The VIROC Gets Revamped For 2020 Lucas Oil Chili Bowl Nationals Presented by General Tire</a>
</li>
<li class="odd">
<a ondragstart="return false;" href="/index.php/news/speedway-news/54088-take-advantage-of-40-food-city-500-tickets-at-all-food-city-locations-through-dec-31">Take advantage of $40 Food City 500 tickets at all Food City locations through Dec. 31</a>
</li>
<li class="even">
<a ondragstart="return false;" href="/index.php/news/speedway-news/54086-ism-raceway-and-local-nascar-drivers-deliver-speedy-bears-to-children-at-banner-children-s-hospital">ISM Raceway and local NASCAR drivers deliver Speedy Bears to children at Banner Children's Hospital</a>
</li>
</ul>
<div class="clr"></div>
</div>
<div class="clr"></div>

<div class="itemNavigation">
<span class="itemNavigationTitle">More in this category:</span>
<a ondragstart="return false;" class="itemPrevious" href="/index.php/news/nascar-cup-series-news/54067-oscar-mayer-launches-mynumber6-contest">
&laquo; Oscar Mayer Launches #MyNumber6 Contest </a>
<a ondragstart="return false;" class="itemNext" href="/index.php/news/nascar-cup-series-news/54079-nashville-becomes-nascar-city-for-champion-s-week">
Nashville becomes “NASCAR City” for Champion’s Week &raquo;
</a>
</div>


<div class="itemBackToTop">
<a ondragstart="return false;" class="k2Anchor" href="/index.php/news/nascar-cup-series-news/54078-corey-lajoie-set-for-second-season-with-go-fas-racing#startOfPageId54078">
back to top </a>
</div>
<div class="clr"></div>
</div>


</div></section></div>
</div></section></div>
<aside id="sp-right" class="span4 hidden-phone hidden-tablet"><div class="module ">
<div class="mod-wrapper clearfix">
<div class="mod-content clearfix">
<div class="mod-inner clearfix">
<div class="custom">
<center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-4983971213106691" data-ad-slot="1975255967"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></center></div>
</div>
</div>
</div>
</div>
<div class="gap"></div>
<div class="module ">
<div class="mod-wrapper clearfix">
<div class="mod-content clearfix">
<div class="mod-inner clearfix">
<div class="custom">
<center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-4983971213106691" data-ad-slot="1975255967"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></center></div>
</div>
</div>
</div>
</div>
<div class="gap"></div>
</aside>
</div></div></section><footer id="sp-footer-wrapper" class=" "><div class="container"><div class="row-fluid" id="footer">
<div id="sp-footer1" class="span6"><span class="copyright">Copyright © 2010 - 2019 STS Motorsports Inc. All Rights Reserved.</span><span class="designed-by">Designed by Steven B. Wilson </span> <a ondragstart="return false;" href="http://www.joomshaper.com" title="joomshaper.com"></a></div>
<div id="sp-footer2" class="span6"><a ondragstart="return false;" class="sp-totop" href="javascript:;" title="Goto Top" rel="nofollow"><small>Goto Top </small><i class="icon-angle-up"></i></a><ul class="nav ">
<li class="item-1557"><a ondragstart="return false;" href="/index.php/advertise">Advertise</a></li><li class="item-1559"><a ondragstart="return false;" href="/index.php/privacy-policy">Privacy Policy</a></li><li class="item-1621"><a ondragstart="return false;" href="/index.php/sitemap">Sitemap</a></li><li class="item-1558"><a ondragstart="return false;" href="/index.php/sd-staff">SD Staff</a></li><li class="item-1576"><a ondragstart="return false;" href="/index.php/writer-login">Writer Login</a></li></ul>
</div>
</div></div></footer> <script type="text/javascript">
        var _gaq = _gaq || [];
        _gaq.push(['_setAccount', 'UA-80147-10']);
        _gaq.push(['_trackPageview']);

        (function() {
        var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
        ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
        var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
        })();
        </script>
<a ondragstart="return false;" class="hidden-desktop btn btn-inverse sp-main-menu-toggler" href="#" data-toggle="collapse" data-target=".nav-collapse">
<i class="icon-align-justify"></i>
</a>
<div class="hidden-desktop sp-mobile-menu nav-collapse collapse">
<ul class=""><li class="menu-item first"><a ondragstart="return false;" href="https://speedwaydigest.com/" class="menu-item first"><span class="menu"><span class="menu-title">Home</span></span></a></li><li class="menu-item active parent"><a ondragstart="return false;" href="/index.php/news" class="menu-item active parent"><span class="menu"><span class="menu-title">News</span></span></a><span class="sp-menu-toggler collapsed" data-toggle="collapse" data-target=".collapse-186"><i class="icon-angle-right"></i><i class="icon-angle-down"></i></span><ul class="collapse collapse-186"><li class="menu-item active first"><a ondragstart="return false;" href="/index.php/news/nascar-cup-series-news" class="menu-item active first"><span class="menu"><span class="menu-title">NASCAR Cup Series News</span></span></a></li><li class="menu-item"><a ondragstart="return false;" href="/index.php/news/xfinity-series-news" class="menu-item"><span class="menu"><span class="menu-title">Xfinity Series News</span></span></a></li><li class="menu-item"><a ondragstart="return false;" href="/index.php/news/nascar-truck-series-news" class="menu-item"><span class="menu"><span class="menu-title">NASCAR Truck Series News</span></span></a></li><li class="menu-item"><a ondragstart="return false;" href="/index.php/news/speedway-news" class="menu-item"><span class="menu"><span class="menu-title">Speedway News</span></span></a></li><li class="menu-item"><a ondragstart="return false;" href="/index.php/news/racing-news" class="menu-item"><span class="menu"><span class="menu-title">Racing News</span></span></a></li><li class="menu-item last"><a ondragstart="return false;" href="/index.php/news/latest-news" class="menu-item last"><span class="menu"><span class="menu-title">Latest News</span></span></a></li></ul></li><li class="menu-item parent"><a ondragstart="return false;" href="/index.php/nascar-schedules" class="menu-item parent"><span class="menu"><span class="menu-title">Schedules</span></span></a><span class="sp-menu-toggler collapsed" data-toggle="collapse" data-target=".collapse-197"><i class="icon-angle-right"></i><i class="icon-angle-down"></i></span><ul class="collapse collapse-197"><li class="menu-item first"><a ondragstart="return false;" href="/index.php/nascar-schedules/nascar-cup-series-schedule" class="menu-item first"><span class="menu"><span class="menu-title">NASCAR Cup Series Schedule</span></span></a></li><li class="menu-item"><a ondragstart="return false;" href="/index.php/nascar-schedules/xfinity-series-schedule" class="menu-item"><span class="menu"><span class="menu-title">Xfinity Series Schedule</span></span></a></li><li class="menu-item"><a ondragstart="return false;" href="/index.php/nascar-schedules/nascar-truck-series-schedule" class="menu-item"><span class="menu"><span class="menu-title">NASCAR Truck Series Schedule</span></span></a></li><li class="menu-item last"><a ondragstart="return false;" href="/index.php/nascar-schedules/weekend-schedule" class="menu-item last"><span class="menu"><span class="menu-title">Weekend Schedule</span></span></a></li></ul></li><li class="menu-item parent"><a ondragstart="return false;" href="/index.php/point-standings" class="menu-item parent"><span class="menu"><span class="menu-title">Point Standings</span></span></a><span class="sp-menu-toggler collapsed" data-toggle="collapse" data-target=".collapse-208"><i class="icon-angle-right"></i><i class="icon-angle-down"></i></span><ul class="collapse collapse-208"><li class="menu-item first"><a ondragstart="return false;" href="/index.php/point-standings/nascar-cup-series" class="menu-item first"><span class="menu"><span class="menu-title">NASCAR Cup Series</span></span></a></li><li class="menu-item"><a ondragstart="return false;" href="/index.php/point-standings/xfinity-series" class="menu-item"><span class="menu"><span class="menu-title">Xfinity Series</span></span></a></li><li class="menu-item last"><a ondragstart="return false;" href="/index.php/point-standings/nascar-truck-series" class="menu-item last"><span class="menu"><span class="menu-title">NASCAR Truck Series</span></span></a></li></ul></li><li class="menu-item parent"><a ondragstart="return false;" href="/index.php/scanner-frequencies" class="menu-item parent"><span class="menu"><span class="menu-title">Scanner Frequencies</span></span></a><span class="sp-menu-toggler collapsed" data-toggle="collapse" data-target=".collapse-204"><i class="icon-angle-right"></i><i class="icon-angle-down"></i></span><ul class="collapse collapse-204"><li class="menu-item first"><a ondragstart="return false;" href="/index.php/scanner-frequencies/nascar-cup-series-frequencies" class="menu-item first"><span class="menu"><span class="menu-title">NASCAR Cup Series Frequencies</span></span></a></li><li class="menu-item"><a ondragstart="return false;" href="/index.php/scanner-frequencies/xfinity-frequencies" class="menu-item"><span class="menu"><span class="menu-title">Xfinity Frequencies</span></span></a></li><li class="menu-item"><a ondragstart="return false;" href="/index.php/scanner-frequencies/nascar-truck-series-frequencies" class="menu-item"><span class="menu"><span class="menu-title">NASCAR Truck Series Frequencies</span></span></a></li><li class="menu-item last"><a ondragstart="return false;" href="/index.php/scanner-frequencies/arca-series-frequencies" class="menu-item last"><span class="menu"><span class="menu-title">ARCA Series Frequencies </span></span></a></li></ul></li><li class="menu-item last"><a ondragstart="return false;" href="/index.php/writers-wanted" class="menu-item last"><span class="menu"><span class="menu-title">Writers Wanted</span></span></a></li></ul>
</div>
<script type="text/javascript">
            
            jQuery(function($){
                var carousel = jQuery('.carousel');
                if(carousel){
                    window.addEvent('domready', function(){
                        if (typeof jQuery != 'undefined' && typeof MooTools != 'undefined' ) {
                            Element.implement({
                                slide: function(how, mode){
                                    return this;
                                }
                            });
                        }
                    });
                };
            });
        </script>
</div>
<div id="redim-cookiehint-bottom"> <div id="redim-cookiehint"> <div class="cookiecontent"> Cookies make it easier for us to provide you with our services. With the usage of our services you permit us to use cookies. </div> <div class="cookiebuttons"> <a ondragstart="return false;" id="cookiehintsubmit" onclick="return cookiehintsubmitno(this);" href="https://speedwaydigest.com/index.php/news/nascar-cup-series-news/54078-corey-lajoie-set-for-second-season-with-go-fas-racing?rCH=2" class="btn">Ok</a> <a ondragstart="return false;" id="cookiehintsubmitno" onclick="return cookiehintsubmitno(this);" href="https://speedwaydigest.com/index.php/news/nascar-cup-series-news/54078-corey-lajoie-set-for-second-season-with-go-fas-racing?rCH=-2" class="btn">Decline</a> </div> <div class="clr"></div> </div> </div> <script type="text/javascript">       function cookiehintfadeOut(el) {         el.style.opacity = 1;         (function fade() {           if ((el.style.opacity -= .1) < 0) {             el.style.display = "none";           } else {             requestAnimationFrame(fade);           }         })();       }         function cookiehintsubmit(obj) {         document.cookie = 'reDimCookieHint=1; expires=Fri, 04 Dec 2020 23:59:59 GMT;57; path=/';         cookiehintfadeOut(document.getElementById('redim-cookiehint-bg'));         return false;       }        function cookiehintsubmitno(obj) {         document.cookie = 'reDimCookieHint=-1; expires=0; path=/';         cookiehintfadeOut(document.getElementById('redim-cookiehint-bg'));         return true;       }     </script>
<script type="text/javascript">
	disableSelection(document.body)
</script>
<script type="text/javascript">
	if (top!==self) {
		top.location=location;
	}
</script>
</body>
</html>